




<!-- hearst/article/article_main.tpl -->

            <!-- hearst/article/articleMain.tpl -->



    
        <!doctype html>
<html class="no-js "  lang="en-US" prefix="og: http://ogp.me/ns#  article: http://ogp.me/ns/article#">
    <head>

    <!-- Includes for HashTag Labs -->
    
    <!-- eid:article.17441768 -->
    <!-- generated at 2022-09-15 04:08:45 on pwcm7 running vv13.5.5 -->
    <!-- hearst/article/headerMain.tpl -->
            <!-- hmb:jquery jQuery JS -->
        <script type="text/javascript" src="/js/core/libs/jquery-2.2.4.min.js"></script>
                <!-- hmb:treg TREG JS -->
        <script type="text/javascript">window.tregEnabled = true;</script>
        <script type="text/javascript" src="//treg.hearstnp.com/treg.js"></script>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
            <!-- hmb:taboola Sailthru  -->
        <!-- hearst/home/header_sailthru.tpl -->
<meta property="sailthru.title" content="'A no-brainer': Trumbull school board backs plan to name band room for late Peter Horton" /><meta name="sailthru.date" content="2022-09-14 17:36:00 -0400" /><meta name="sailthru.description" content="Peter Horton, who lead Trumbull High School’s Golden Eagle Marching Band and spent 30 years as a music teacher before retiring in 2020, died in July." /><meta name="sailthru.author" content="Amanda Cuda" /><meta name="sailthru_uid" content="17441768" /><meta name="sailthru_pubname" content="trumbull-times" /><meta name="sailthru_siteid" content="78" /><meta name="sailthru.tags" content="peter-horton,amy-lafond,lianna-weaver,pete,lucinda-timpanelli,susan-iwanicki,jackie-norcel,peter,trumbull,trumbull-high-school,golden-eagle-marching-band,board-of-education,trumbulltimes,connecticut-post,trumbull-board-of-education,the-peter-g-horton-band-room,from-the-heart,the-peter-g-horton-band-room-play-from-the-heart,pride-attitude,pride-attitude-concentration,play-from-the-heart,trumbull-high-school,golden-eagle-marching-band,board-of-education,trumbulltimes,connecticut-post,trumbull-board-of-education,peter-horton,amy-lafond,lianna-weaver,pete,lucinda-timpanelli,susan-iwanicki,jackie-norcel,peter,trumbull,the-peter-g-horton-band-room,from-the-heart,the-peter-g-horton-band-room-play-from-the-heart,pride-attitude,pride-attitude-concentration,play-from-the-heart,2fjobs-26-education-2feducation,2farts-26-entertainment-2fmusic-26-audio" /><meta name="sailthru.image.thumb" content="https://s.hdnux.com/photos/01/26/51/22/22713481/7/sailthruImage.jpg" />
<!-- e hearst/home/header_sailthru.tpl -->
    
            <title>Trumbull school board supports naming band room for Peter Horton</title>
    <!-- hearst/common/fonts.tpl -->
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-italic.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-regular.woff" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-700.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-300.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-600.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-700.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-italic.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<!-- e hearst/common/fonts.tpl -->

        <script>
          if ( document.location.hostname.match(/\.$/) ) {
              document.location.replace(
                  document.location.protocol +
                  '//' +
                  document.location.hostname.replace(/\.+$/, '') +
                  ( undefined !== document.location.pathname ? document.location.pathname : '' ) +
                  ( undefined !== document.location.search ? document.location.search : '' )  +
                  ( undefined !== document.location.hash ? document.location.hash : '' )
              );
          }
        </script>

    <script>
                var HDN = HDN || {};
        HDN.t_firstbyte = Number(new Date());
        HDN.dataLayer = HDN.dataLayer || {};
        HDN.dataLayer.content = HDN.dataLayer.content || {};
                HDN.dataLayer.paywall = HDN.dataLayer.paywall || {};
        HDN.dataLayer.paywall.accessRule = "";
        HDN.dataLayer.paywall.mode = "";
        var Article = {
            "id": "17441768",
            "title": "&#039;A no-brainer&#039;: Trumbull school board backs plan to name band room for late Peter Horton",
            "url": "https://www.trumbulltimes.com/news/article/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php",
            "slug": "https://www.trumbulltimes.com/news/article/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php",
            "summary": "The Board of Education is supporting a plan to name the Trumbull High School band room...",
            "image": "https://s.hdnux.com/photos/01/26/51/22/22713481/7/rawImage.jpg",
            "keywords": "",
            "siteName": "Trumbull Times",
            "env": "pwcm7",
            "comments": true,
            "isSensitive": false,
            "version": "v13.5.5",
            "displayTemplate": "dynamic_two_column",
            "renderNLP": true,
            "timing": {
                "firstbyte": HDN.t_firstbyte,
                "ready": {}
            }
        };
        
        document.addEventListener('DOMContentLoaded', function () {
            Article.timing.ready = Number(new Date());
        }, false);
        
    </script>
        
    <!-- hearst/common/hdn_datalayer_header.tpl -->

                                                                
<script type="text/javascript">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</script>
<!-- e hearst/common/hdn_datalayer_header.tpl -->
    <script type="text/javascript" src="/js/site.js?v13.5.5"></script>
            
            <!-- Hotfix Top Freeform (All Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.94216 -->
<!-- DO NOT REMOVE -->
<script src="https://projects.sfchronicle.com/shared/js/responsive-frame.js"></script>
<!-- e DO NOT REMOVE -->
        <!-- Hotfix Top Freeform (Local Dynamic Two-Column) -->
        
<!-- noGen: item_header_hotfix_top_dtc_ssl 78 dne  -->
                <link rel="stylesheet" href="/dist/article.min.css?v13.5.5">
                            <!-- hmb:Polyfill  -->
        <script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=IntersectionObserver%2CIntersectionObserverEntry%2CPromise%2CCustomEvent%2CArray.prototype.forEach%2CArray.prototype.entries"></script>
                <!-- hmb:js_header Static JS Bundle  -->
        <script type="text/javascript" src="/dist/hdn/article.min.js?v13.5.5"></script>
        <!-- hearst/article/common/meta_tags.tpl -->
<meta name="msvalidate.01" content="9451CA04ABC9D1D5C6419C73B4C4F7B7" />
<meta name="HandheldFriendly" content="true">
<meta name="twitter:dnt" content="on">
<meta name="apple-mobile-web-app-title" content="">
<meta name="environment" content="pwcm7">
<meta name="id" content="17441768">
<link rel="canonical" href="https://www.trumbulltimes.com/news/article/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php" />
                                        <meta name="author" content="Amanda Cuda">
        <meta name="author.name" content="Amanda Cuda" />
        <meta name="author.title" content="" />
        <meta name="description" content="Peter Horton, who lead Trumbull High School’s Golden Eagle Marching Band and spent 30 years as a music teacher before retiring in 2020, died in July."/>
    <meta name="date.release" content="2022-09-14 19:54:16" />
    <meta name="time.release" content="2022-09-14 19:54:16" />
    <meta name="sections" content="News" />
            <meta name="robots" content="max-image-preview:large">
                <meta name="subject" content="Peter Horton, Amy Lafond, Lianna Weaver, Pete, Lucinda Timpanelli, Susan Iwanicki, Jackie Norcel, Peter, Trumbull, Trumbull High School, Golden Eagle Marching Band, Board of Education, TrumbullTimes, Connecticut Post, Trumbull Board of Education, The Peter G. Horton Band Room, From the Heart, The Peter G. Horton Band Room 'Play From the Heart!, Pride -- Attitude, Pride -- Attitude -- Concentration, Play From the Heart" />
        <meta name="news_keywords" content="Peter Horton, Amy Lafond, Lianna Weaver, Pete, Lucinda Timpanelli, Susan Iwanicki, Jackie Norcel, Peter, Trumbull, Trumbull High School, Golden Eagle Marching Band, Board of Education, TrumbullTimes, Connecticut Post, Trumbull Board of Education, The Peter G. Horton Band Room, From the Heart, The Peter G. Horton Band Room 'Play From the Heart!, Pride -- Attitude, Pride -- Attitude -- Concentration, Play From the Heart" />
                <meta name="nlpOrganization" content="Trumbull High School, Golden Eagle Marching Band, Board of Education, TrumbullTimes, Connecticut Post, Trumbull Board of Education" />
                <meta name="nlpPerson" content="Peter Horton, Amy Lafond, Lianna Weaver, Pete, Lucinda Timpanelli, Susan Iwanicki, Jackie Norcel, Peter" />
                <meta name="nlpLocation" content="Trumbull" />
                    <meta name="nlpWorkOfArt" content="The Peter G. Horton Band Room, From the Heart, The Peter G. Horton Band Room 'Play From the Heart!, The Peter G. Horton Band Room 'Play From the Heart!" />
                    <meta name="nlpOther" content="Pride -- Attitude, Pride -- Attitude -- Concentration, Play From the Heart" />
                            <meta name="nlpCategories" content="%2FJobs+%26+Education%2FEducation,%2FArts+%26+Entertainment%2FMusic+%26+Audio" />
    <!-- e hearst/article/common/meta_tags.tpl -->    <!-- hearst/article/common/opengraph.tpl -->
<meta property="fb:admins" content="100006394927810"/><meta property="fb:app_id" content="144437386474062"/><meta property="fb:pages" content="105702905593" /><meta property="fb:pages" content="307851324523" /><meta property="fb:pages" content="12852567813" /><meta property="fb:pages" content="480760515417232" /><meta property="fb:pages" content="288240529145" /><meta property="fb:pages" content="316774245761" /><meta property="fb:pages" content="984197758297116" /><meta property="fb:pages" content="7457442370" /><meta property="fb:pages" content="207033189701" /><meta property="fb:pages" content="207346283795" /><meta property="fb:pages" content="222959748728" /><meta property="fb:pages" content="207042068180" /><meta property="fb:pages" content="72983690774" /><meta property="fb:pages" content="339413234035" /><meta property="fb:pages" content="343689323559" /><meta property="fb:pages" content="345828366626" /><meta property="fb:pages" content="234821559861394" /><meta property="fb:pages" content="335699426867" /><meta property="fb:pages" content="10150105039485602" /><meta property="fb:pages" content="338983127562" /><meta property="fb:pages" content="364516539001" /><meta property="fb:pages" content="337922332042" /><meta property="fb:pages" content="115637335153191" /><meta property="fb:pages" content="372011535931" /><meta property="fb:pages" content="333376634908" /><meta property="fb:pages" content="127590790608884" /><meta property="fb:pages" content="141923885872653" /><meta property="fb:pages" content="655037391286291" /><meta property="fb:pages" content="320774811368833" /><meta property="fb:pages" content="1740489152861748" /><meta property="fb:pages" content="469700473093040" /><meta property="fb:pages" content="386754203367" /><meta property="fb:pages" content="556449374478585" /><meta property="fb:pages" content="340999853450" /><meta property="fb:pages" content="350771491032" /><meta property="fb:pages" content="1120648627959218" /><meta property="fb:pages" content="342017778245" /><meta property="fb:pages" content="338463361591" /><meta property="fb:pages" content="138772706196968" /><meta property="fb:pages" content="1641688532739111" /><meta property="fb:pages" content="326312697536" /><meta property="fb:pages" content="353120110016" /><meta property="fb:pages" content="343366744658" /><meta property="fb:pages" content="335009494554" /><meta property="fb:pages" content="347261603104" /><meta property="fb:pages" content="350924013892" /><meta property="fb:pages" content="257724773860" /><meta property="fb:pages" content="361203926417" /><meta property="fb:pages" content="367174215398" /><meta property="fb:pages" content="284154645394" /><meta property="fb:pages" content="334501182354" /><meta property="fb:pages" content="350279743224" /><meta property="fb:pages" content="154340691263654" /><meta property="fb:pages" content="147848678611852" /><meta property="fb:pages" content="361381078011" /><meta property="fb:pages" content="362831597677" /><meta property="fb:pages" content="10150095255780118" /><meta name="og:datePublished" content="2022-09-14 19:54:16"/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta property="og:title" content="'A no-brainer': Trumbull school board backs plan to name band room for late Peter Horton"/><meta property="og:description" content="The Board of Education is supporting a plan to name the Trumbull High School band room..."/><meta property="og:url" content="https://www.trumbulltimes.com/news/article/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php"/><meta property="og:site_name" content="Trumbull Times"/><meta property="og:image" content="https://s.hdnux.com/photos/01/26/51/22/22713481/7/rawImage.jpg"/><meta property="article:published_time" content="2022-09-14 19:54:16" /><meta property="article:modified_time" content="2022-09-14 21:36:53" /><meta property="article:author" content="Amanda Cuda"/><meta property="article:section" content="News" /><meta property="article:tag" content="Peter Horton" /><meta property="article:tag" content="Amy Lafond" /><meta property="article:tag" content="Lianna Weaver" /><meta property="article:tag" content="Pete" /><meta property="article:tag" content="Lucinda Timpanelli" /><meta property="article:tag" content="Susan Iwanicki" /><meta property="article:tag" content="Jackie Norcel" /><meta property="article:tag" content="Peter" /><meta property="article:tag" content="Trumbull" /><meta property="article:tag" content="Trumbull High School" /><meta property="article:tag" content="Golden Eagle Marching Band" /><meta property="article:tag" content="Board of Education" /><meta property="article:tag" content="TrumbullTimes" /><meta property="article:tag" content="Connecticut Post" /><meta property="article:tag" content="Trumbull Board of Education" /><meta property="article:tag" content="The Peter G. Horton Band Room" /><meta property="article:tag" content="From the Heart" /><meta property="article:tag" content="The Peter G. Horton Band Room &#039;Play From the Heart!" /><meta property="article:tag" content="Pride -- Attitude" /><meta property="article:tag" content="Pride -- Attitude -- Concentration" /><meta property="article:tag" content="Play From the Heart" />
<!-- e hearst/article/common/opengraph.tpl -->    <!-- hearst/article/common/twittercard.tpl -->

<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:image" content="https://s.hdnux.com/photos/01/26/51/22/22713481/7/rawImage.jpg"/>
<meta name="twitter:description" content="The Board of Education is supporting a plan to name the Trumbull High School band room..."/>
<meta name="twitter:title" content="'A no-brainer': Trumbull school board backs plan to name band room for late Peter Horton"/>
<meta name="twitter:site" content="@trumbulltimes" />
<!-- e hearst/article/common/twittercard.tpl -->    <!-- hearst/article/common/analytics.tpl -->
<script>var omni_channelPath = "News";var omni_title = "'A no-brainer': Trumbull school board backs plan to name band room for late Peter Horton";var omni_bizObjectId = "17441768";var omni_className = "article";var omni_publicationDate = "2022-09-14 19:54:16";var omni_sourceSite ="trumbulltimes";var omni_authorName = "Amanda Cuda";var omni_authorTitle = "";var omni_premiumStatus = "free";var omni_premiumEndDate = "";var omni_originalSource = "";var omni_pageNumber = "0";var omni_breakingNewsFlag = "";var omni_localNewsFlag = "";var omni_isListView = "0";var omni_paywallSite = "0";var omni_displayTemplate = "dynamic_two_column";</script>
<!-- e hearst/article/common/analytics.tpl -->    <!-- hearst/article/common/schema_NewsArticle.tpl -->

<script type="application/ld+json">
{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@id":"https:\/\/www.trumbulltimes.com\/news\/article\/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php"},"headline":"Trumbull school board supports naming band room for Peter Horton","image":["https:\/\/s.hdnux.com\/photos\/01\/26\/51\/22\/22713481\/7\/ratio3x2_1800.jpg","https:\/\/s.hdnux.com\/photos\/01\/26\/51\/22\/22713481\/7\/ratio3x2_700.jpg","https:\/\/s.hdnux.com\/photos\/01\/26\/51\/22\/22713481\/7\/square_small.jpg"],"articleBody":"TRUMBULL \u2014 In the four years Amy Lafond spent as a student of Peter Horton, she never stopped being in awe of him. Horton, who died in July, was the director of Trumbull High School's Golden Eagle Marching Band. He taught music for 30 years until his retirement in 2020. In that time, he influenced countless students, including Lafond, who was a student of his from 1989 to 1993. She also served as a drum major in the band from 1991 to 1993. Lafond said, when Horton conducted, it was as though his hands were creating music out of thin air. \"Pete was an inspiration,\" she said. \"Watching him conduct was the reason why I became a music teacher. It\u2019s like having a superpower.\" Lafond was part of a committee that met recently to discuss naming the band room at Trumbull High School after Horton. She and other committee members spoke at Tuesday's Trumbull Board of Education meeting and presented their findings. All who spoke talked about Horton's enthusiasm for music, including current band student Lianna Weaver. Weaver, who is also Horton's granddaughter, said she remembers watching Horton work when she was an elementary or middle school student who parked outside the band room, waiting for Horton to finish up. \"I saw him constantly working with (the students), constantly teaching them,\" she said. \"I saw his passion.\"\u00a0 Assistant Superintendent of Schools Susan Iwanicki explained that the committee had come up with three potential names for the band room: \"The Peter G. Horton Band Room, Pride \u2013 Attitude \u2013 Concentration 'From the Heart'\"; \"The Peter G. Horton Band Room 'From the Heart!' Pride \u2013 Attitude \u2013 Concentration\"; \"The Peter G. Horton Band Room 'Play From the Heart!'\" All the potential names incorporated some version of phrases Horton commonly used. Board of Education chair Lucinda Timpanelli said, given that Horton was such a beloved figure in the community, naming the band room for him was \"a no-brainer.\" \"I worked with Peter,\" she said. \"He was a good man, always a good man.\" Timpanelli said her preference for the room name was the \"Play From the Heart\" option, as that's the expression she most associated with him.\u00a0 Ultimately, that option was the one that got the most support from the board, with five members for it. Board member Jackie Norcel asked if the words \"Pride \u2013 Attitude \u2013 Concentration\" could be added to that name, and Lafond said it's something the committee would consider, and bring their thought back to the board. Eventually, the board voted to recommend naming the room \"The Peter G. Horton Band Room 'Play From the Heart!' \" and adding the words \u00a0\"Pride \u2013 Attitude \u2013 Concentration.\" In her presentation, Lafond emphasized that renaming the room for Horton was important given the impact he had. \"I just hope that, 30 years from now, I have a student who will get up and speak about me the way I\u2019ve heard so many people speak about Pete,\" she said. \u00a0","datePublished":"2022-09-14T19:54:16Z","dateModified":"2022-09-14T21:36:53Z","author":[{"@type":"Person","name":"Amanda Cuda","jobTitle":""}],"publisher":{"@type":"Organization","name":"Trumbull Times","logo":{"@type":"ImageObject","url":"https:\/\/www.TrumbullTimes.com\/img\/ldjson_logo.png","width":600,"height":60},"sameAs":["http:\/\/facebook.com\/trumbulltimes","http:\/\/twitter.com\/trumbulltimes"]},"description":"The Board of Education is supporting a plan to name the Trumbull High School band room..."}
</script>
<!-- e hearst/article/common/schema_NewsArticle.tpl -->        <!-- hearst/common/third_party_assets.tpl -->
                    <!-- hmb:juice Juice -->
        <script type="text/javascript">
            
                var startRevWorker = function() {
                    if (window.articleShowLISTQueue) {
                        while (window.articleShowLISTQueue.length > 0) {
                            var showListEntry = articleShowLISTQueue.shift();
                            window.aps.showLIST([showListEntry]);
                        }
                    }
                    if (window.placeAdQueue) {
                        while (window.placeAdQueue.length > 0) {
                            var placeAdEntry = placeAdQueue.shift();
                            window.aps.placeAd([placeAdEntry]);
                        }
                    }
                    if (window.slideshowShowLISTQueue) {
                        while (window.slideshowShowLISTQueue.length > 0) {
                            var ads = window.slideshowShowLISTQueue.shift();
                            window.aps.showLIST(ads);
                        }
                    }
                    window.juiceloaded = true;
                }
            
        </script>

        <!-- ENG-10074 If AB Test on Seattle we turn off Juice in order to use HTL code -->
                    <script  src="https://aps.hearstnp.com/Scripts/loadAds.js?v=1.3.3.5" type="text/javascript" id="adPositionManagerScriptTag"></script>
            
    <!-- hmb:ensighten Ensighten  -->
    <!-- hearst/ensighten/ensighten.tpl -->
<!-- hmb:ensighten Ensighten script -->
<!-- Hearst analytics: Ensighten -->
<script src="https://tm.hdmtools.com/hearst/news/Bootstrap.js"></script>
<!-- End Hearst analytics: Ensighten -->
<!-- e ensighten.tpl -->                    <!-- blueconic -->
        <script src="https://o398.trumbulltimes.com/script.js" async></script>
            
    <!-- hmb:taboola Taboola  -->
                            
                            
                <script type="text/javascript">
                    
                    (function () {
                        window._taboolaNetworkMode = true;
                        
                        window._taboola = window._taboola || [];
                        window._taboolaHDNPageLabel = window._taboolaHDNPageLabel || 'article';
                        var tobj = {};
                        tobj[window._taboolaHDNPageLabel] = 'auto';
                        window._taboola.push(tobj);
                        !function (e, f, u, i) {
                            if (!document.getElementById(i)){
                                e.async = 1;
                                e.src = u;
                                e.id = i;
                                f.parentNode.insertBefore(e, f);
                            }
                        }(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/hearstlocalnews-network/loader.js', 'tb_loader_script');
                        if(window.performance && typeof window.performance.mark == 'function') {
                            window.performance.mark('tbl_ic');
                        }
                    })();
                </script>
                
                                <!-- e hearst/common/third_party_assets.tpl -->
    <link rel="shortcut icon" href="/favicon.ico">
    <link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon.png">
    <link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png">
    <link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png">
    <link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png">
    <link rel="apple-touch-icon-precomposed" sizes="128x128" href="/apple-touch-icon-128x128.png">
            <!-- Hotfix Freeform (All Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.93530 -->
<!-- ENG-3363 -->
<style>
  .thumbnailListAuthor.one .thumbnailListAuthor--wrapper { margin: 0; }
  @media (min-width: 768px) { .thumbnailListAuthor.two .thumbnailListAuthor--wrapper { margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--items { justify-content: space-between; margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--item { flex: 0 0 48%; margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--spacer { display: none; } }
  @media (min-width: 928px) { .thumbnailListAuthor.three .thumbnailListAuthor--wrapper { margin: 0; } }
</style>
<!-- ENG-3834 -->
<style>
  .alert{background-color:#000;bottom:0;box-sizing:border-box;color:#fff;font-family:Helvetica,sans-serif;font-size:16px;font-weight:600;left:50%;line-height:1.25;overflow:hidden;padding:10px;position:fixed;transform:translateX(-50%);width:100vw;z-index:5000000}.alert .close{border-radius:8px;color:#fff;display:block;position:absolute;right:10px;height:16px;overflow:hidden;top:10px;width:16px}.alert .close::after{background-color:#fff;content:'';display:block;height:2px;left:-6px;position:relative;top:4px;transform:rotate(-45deg);width:30px}.alert .close::before{background-color:#fff;content:'';display:block;height:2px;left:-5px;position:relative;top:9px;transform:rotate(45deg);width:30px}.alert>div{box-sizing:border-box;max-width:1200px;margin:0 auto;position:relative;padding-right:34px}
</style>
<script>
  document.addEventListener('DOMContentLoaded', function() {
    if (/MSIE \d|Trident.*rv:/.test(navigator.userAgent)) {var site=HDN.domain,name=site.charAt(0).toUpperCase()+site.slice(1),section=document.createElement("section"),close=document.createElement("a");close.className="close",close.href="#",close.addEventListener("click",function(e){e.stopPropagation(),e.preventDefault(),e.target.parentElement.style.display="none"});var HTML="<div>Thank you for visiting "+name+". You are using an older browser that may impact your reading experience. For the best experience, we recommend you use Chrome, Safari, Firefox, or Edge.</div>";section.className="alert",section.id="warning",section.innerHTML=HTML,section.appendChild(close),document.getElementsByTagName("body")[0].appendChild(section);}
  }, false);
</script>
<!-- e ENG-3834 -->
<!--  Start ENG-8221 -->
<style>
@media (max-width:768px) {   
  .articleHeader:not(.heroleft):not(.herotextabove):not(.herocenter) .articleHeader--timestamp {     
    bottom: 0px !important;     
    margin-left: 0px !important;     
    position: relative;    
  }
}</style>
        <!-- Hotfix Freeform (Local Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.97470 -->
<!-- ENG-10491 -->
<style>
  .badge:not(.shopping):not(.sponsored-content):not(.paidad-content):before, 
  section.fourPack-breaking .fourPack--item .badge::before, 
  section.centerpiece .centerpiece-tab-primary.density>div:last-child .centerpiece-tab 
  .badge::before {
    display: none;
  }
  .thumbnail-list a.hideKicker, 
  .centerpiece div.hideKicker, 
  .dynamicSpotlight div.hideKicker, 
  .thumbnail-list div.hideKicker, 
  .thumbnail-list span.hideKicker,
  .dynamicSpotlight span.hideKicker {
    display: inherit;
  }
  .dynamicSpotlight div.hideKicker, 
  .dynamicSpotlight span.hideKicker {
    display: inline-block;
  }
  .centerpiece .badgeInline p.bullet span {
    display: none;
  }
  .centerpiece:not(.density) div.centerpiece-tab--main-kicker.hideKicker {
    display: block;
  }
  .thumbnail-list--item-header.badge.shopping .hideKicker > a, .thumbnail-list--item-header.badge.shopping .hideKicker > span {
    display: none;
  }
</style>
                    </head>
<!-- e hearst/article/headerMain.tpl -->    <body data-location="news"  class="two-column">
                                                <!-- design/article/dynamic_two_column.tpl -->
    <!-- hearst/article/types/dynamic_two_column.tpl -->


<div id="zoneTop" class="zone full innerGrid" data-tb-region="zoneAboveMasthead"></div><!-- hearst/common/siteBranding.tpl -->
    <header class="pageHeader standard" data-stage="0">
        <div class="pageHeader--progress"><div class="pageHeader--progress-bar" id="progress"></div></div>    <div class="pageHeader--skipLink-wrapper">
        <a href="#content" class="pageHeader--skipLink" aria-label="Skip to main content">Skip to main content</a>
    </div>
    <div class="pageHeader--wrapper lock">
        <button id="navToggle" class="pageHeader--menuButton navToggle" role="button" tabindex="0" aria-expanded="false" aria-label="navigation"></button>                <a id="mastheadLogo" href="/" tabindex="0">Trumbull Times Homepage<span  class="pageHeader--logo mastheadLogo fade show hdn-analytics" role="img" aria-label="Trumbull Times Homepage - Site Logo" data-hdn-analytics="visit|masthead|navigation|0"></span></a>
                    <div id="titleBar" class="pageHeader--titleBar titleBar fade show hidden">
                                    <div class="pageHeader--titleBar-subsection">Currently Reading</div>
                    <div class="pageHeader--titleBar-title">'A no-brainer': Trumbull school board backs plan to name band room for late Peter Horton</div>
                            </div>
                            <div id="nextStory" class="pageHeader--nextStory nextStory fade show hidden"></div>
                            <ul class="pageHeader--links fade show">
                                                                                                                                        <li id="subscription" class="pageHeader--links-nonsub subscribeButton fade show hidden">
                                <a class="visible-xs-f subscribe" href="https://subscription.hearstmediact.com/checkout/693/1641?siteid=CT_TT&origin=button&ipid=wcm" target="_blank">Subscribe</a>
                                <a class="hidden-xs button" href="https://subscription.hearstmediact.com/checkout/693/1641?siteid=CT_TT&origin=button&ipid=wcm" target="_blank">Subscribe</a>
                            </li>
                                                                                                <li id="eEdition" class="pageHeader--links-sub eEdition fade show hidden"><a href="/e-edition">e-Edition</a></li>
                                                                                                                                        <!-- hearst/common/signin.tpl -->
<li class="treg-is-gigya gigya_menu ">
    <div class="gya-title expandable treg-conditional treg-not-logged-in">
        <a class="signIn featureSignIn" tabindex="0" role="button">Sign In</a>
    </div>
    <div class="gya-title expandable treg-conditional treg-logged-in" aria-controls="treg-login-widget" role="button"><span></span></div>
    <div class="gya-content expandable" id="treg-login-widget">
        <div class="treg-gya-login-widget"></div>
    </div>
</li>
<!-- e hearst/common/signin.tpl -->                <button class="pageHeader--searchButton searchToggle" aria-expanded="false" tabindex="0" aria-label="searchToggle" aria-controls="searchField-aria"></button>            </ul>
                            <div class="pageHeader--search searchField" id="searchField-aria">
                
                <form class="pageHeader--search-form" action="/search/" method="get">
                    <input type="hidden" name="action" value="search" />
                    <input type="hidden" name="firstRequest" value="1" />
                    <input type="hidden" name="searchindex" value="solr" />
                    <div class="fieldset">
                        <input class="pageHeader--search-input" id="search" name="query" type="text" value="" placeholder="Search" aria-label="search" />
                        <button class="searchButton btn" value="" name="search" type="submit" aria-label="search"></button>
                    </div>
                </form>
            </div>
            </div>
                                    
        <!-- hearst/home/HNavigation.tpl -->
<!-- hearst/home/navigation.tpl -->
         <!-- hearst/common/siteNavigation.tpl -->
<nav id="navigation" class="navigation"><div class="navigation--wrapper lock"><div class="navigation--menu"><ul class="hidden-sm hidden-md hidden-lg hidden-xl"><li class="single" data-length="1" data-index="1"><a href="/puzzles/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="6069" data-hdn-analytics="visit|Puzzles|navigation-ard|1">Puzzles</a></li><li class="parent topLevel" data-length="11" data-index="0"><span role="heading" aria-level="2"><a  href="/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5819" data-hdn-analytics="visit|Home|navigation-ard|2">Home</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 220px"><li class="child"><a  href="https://link.trumbulltimes.com/join/signup-tt" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5811" data-hdn-analytics="visit|Home-Sign Up for Newsletters|navigation-ard|1">Sign Up for Newsletters</a></li><li class="child"><a  href="https://subscription.hearstmediact.com/eEdition?siteID=CT_TT" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4928" data-hdn-analytics="visit|Home-E-Edition|navigation-ard|2">E-Edition</a></li><li class="child"><a  href="https://subscription.hearstmediact.com/checkout/693/1641?siteid=CT_TT&origin=hamburger&ipid=wcm" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4927" data-hdn-analytics="visit|Home-Subscribe|navigation-ard|3">Subscribe</a></li><li class="child"><a  href="https://hearstmediact.newsbank.com/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4892" data-hdn-analytics="visit|Home-Print Archives|navigation-ard|4">Print Archives</a></li><li class="child"><a  href="/submissions/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4901" data-hdn-analytics="visit|Home-Submissions|navigation-ard|5">Submissions</a></li><li class="child"><a  href="https://hrstiservices.dticloud.com/hrst-est-cmdb1_cmo/subscriber/web/signin.html?siteId=CTT" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4932" data-hdn-analytics="visit|Home-Delivery Problems|navigation-ard|6">Delivery Problems</a></li><li class="child"><a  href="/contact/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4933" data-hdn-analytics="visit|Home-Contact Us|navigation-ard|7">Contact Us</a></li><li class="child"><a  href="/about-us/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4934" data-hdn-analytics="visit|Home-About Us|navigation-ard|8">About Us</a></li><li class="child"><a  href="/privacy/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4936" data-hdn-analytics="visit|Home-Privacy Notice|navigation-ard|9">Privacy Notice</a></li><li class="child"><a  href="/tos/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4937" data-hdn-analytics="visit|Home-Terms of Use|navigation-ard|10">Terms of Use</a></li></ul></li><li class="parent topLevel" data-length="9" data-index="2"><span role="heading" aria-level="2"><a  href="/news/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5818" data-hdn-analytics="visit|News|navigation-ard|3">News</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 176px"><li class="child"><a  href="/news/police-fire/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4883" data-hdn-analytics="visit|News-Police &amp; Fire|navigation-ard|1">Police &amp; Fire</a></li><li class="child"><a  href="/news/education/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4885" data-hdn-analytics="visit|News-Education|navigation-ard|2">Education</a></li><li class="child"><a  href="/news/town-government/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4889" data-hdn-analytics="visit|News-Town Government|navigation-ard|3">Town Government</a></li><li class="child"><a  href="/news/politics-elections/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4890" data-hdn-analytics="visit|News-Politics &amp; Elections|navigation-ard|4">Politics &amp; Elections</a></li><li class="child"><a  href="/cannabis/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="6090" data-hdn-analytics="visit|News-Cannabis|navigation-ard|5">Cannabis</a></li><li class="child"><a  href="/connecticut/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5836" data-hdn-analytics="visit|News-Connecticut|navigation-ard|6">Connecticut</a></li><li class="child"><a  href="/news/community/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4915" data-hdn-analytics="visit|News-Community|navigation-ard|7">Community</a></li><li class="child"><a  href="/opinion/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5815" data-hdn-analytics="visit|News-Opinion|navigation-ard|8">Opinion</a></li></ul></li><li class="parent topLevel" data-length="2" data-index="3"><span role="heading" aria-level="2"><a  href="/business/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4884" data-hdn-analytics="visit|Business|navigation-ard|4">Business</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/realestate/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5822" data-hdn-analytics="visit|Business-Real Estate|navigation-ard|1">Real Estate</a></li></ul></li><li class="single" data-length="1" data-index="4"><a href="/entertainment/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4886" data-hdn-analytics="visit|Entertainment|navigation-ard|5">Entertainment</a></li><li class="parent topLevel" data-length="3" data-index="5"><span role="heading" aria-level="2"><a  href="/sports/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5816" data-hdn-analytics="visit|Sports|navigation-ard|6">Sports</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/uconn/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5821" data-hdn-analytics="visit|Sports-UConn|navigation-ard|1">UConn</a></li><li class="child"><a  href="/sports/high-school-sports/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4895" data-hdn-analytics="visit|Sports-High School Sports|navigation-ard|2">High School Sports</a></li></ul></li><li class="parent topLevel" data-length="3" data-index="6"><span role="heading" aria-level="2"><a  href="/living/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5820" data-hdn-analytics="visit|Living|navigation-ard|7">Living</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/food_copy_3481_20210205152005/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5830" data-hdn-analytics="visit|Living-Food|navigation-ard|1">Food</a></li><li class="child"><a  href="/homegarden/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5353" data-hdn-analytics="visit|Living-Home and Garden|navigation-ard|2">Home and Garden</a></li></ul></li><li class="single" data-length="1" data-index="7"><a href="https://www.legacy.com/obituaries/trumbulltimes/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5817" data-hdn-analytics="visit|Obituaries|navigation-ard|8">Obituaries</a></li><li class="single" data-length="1" data-index="8"><a href="/shopping/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="6120" data-hdn-analytics="visit|Shopping|navigation-ard|9">Shopping</a></li><li class="parent topLevel" data-length="2" data-index="9"><span role="heading" aria-level="2"><a  href="/sponsoredarticles/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5725" data-hdn-analytics="visit|Advertising Features|navigation-ard|10">Advertising Features</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/events-calendar/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="6012" data-hdn-analytics="visit|Advertising Features-Events|navigation-ard|1">Events</a></li></ul></li><li class="single" data-length="1" data-index="10"><a href="http://connecticut.ipublishmarketplace.com/connecticut-marketplace/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4926" data-hdn-analytics="visit|Classifieds|navigation-ard|1">Classifieds</a></li></ul></div></div><span class="rule"></span><div id="navToggle__page" class="navTogglePage"></div></nav>
<!-- e hearst/common/siteNavigation.tpl -->
<!-- e hearst/home/navigation.tpl --> <!-- e hearst/home/HNavigation.tpl -->    </header>

<!-- e hearst/common/siteBranding.tpl --> <main><section id="topZone" class="zone topZone"><!-- src/business/widgets/hearst/collection/widget.tpl -->

    <div class="hide-rss-link hdnce-e hdnce-collection-111568-dynamic_ribbon_articles"><!-- hearst/collections/dynamic_ribbon_articles.tpl -->
<!-- collection.dynamic_ribbon_articles.111568 -->
    <!-- design/collection/dynamic_ribbon_articles/single_zone.tpl -->
                                                                                                                                                <div class="articleRibbon" aria-label="carousel" role="region" data-component="collection" data-type="ribbon" data-collection-id="111568" data-collection-title="D- TT Article Ribbon News" data-type="list">
        <button class="articleRibbon--nav-btn articleRibbon--nav-prev fade" data-delta="-1" aria-label="Previous"></button>
        <div class="articleRibbon--wrapper">
            <ul class="articleRibbon--list">
                <div class="scrollSpacer"></div>
                                <div class="articleRibbon--list-wrapper" style="flex: 1 0 2200px;">
                    <span class="articleRibbon--list-title" role="heading" aria-level="2"><span class="articleRibbon--list-label"><!-- widgets/hearst/moduleHeader/widget.tpl -->
                                            <h2 role="heading" aria-level="2">Recommended</h2>
                        <!-- e widgets/hearst/moduleHeader/widget.tpl --></span></span>                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php" data-hdn-analytics="visit-from-img|article-17441768|-111568|1">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio1x1_100.jpg" alt="Band director Peter Horton directs a rehearsal of the Trumbull High School Marching Band for their upcoming performance in the Stamford Thanksgiving Day Parade at the school in Trumbull, Conn. on Wednesday, November 16, 2016. The band won the U.S. Bands Class 6 Open National band competition last Saturday, November 12, at Met Life Stadium in New Jersey.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/news/article/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php" data-hdn-analytics="visit|article-17441768|-111568|1" data-epe-inst="s:0;t:75" data-epe-title="1">Trumbull school board backs naming band room after late director</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Survey-Trumbull-residents-want-more-trees-less-17434055.php" data-hdn-analytics="visit-from-img|article-17434055|-111568|2">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/27/32/43/22915295/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/27/32/43/22915295/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/27/32/43/22915295/4/ratio1x1_100.jpg" alt="Trumbull residents were asked to name their top priorities for the town in survey sent out in spring 2022.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/news/article/Survey-Trumbull-residents-want-more-trees-less-17434055.php" data-hdn-analytics="visit|article-17434055|-111568|2" data-epe-inst="s:0;t:75" data-epe-title="1">Survey: Trumbull residents want more trees, less development</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Trumbull-swim-teams-find-a-home-at-University-of-17417386.php" data-hdn-analytics="visit-from-img|article-17417386|-111568|3">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/27/23/70/22887950/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/27/23/70/22887950/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/27/23/70/22887950/4/ratio1x1_100.jpg" alt="Trumbull Pisces coach Jess Daigle instructs a swimmer during tryouts on Aug. 30, 2022 at the University of Bridgeport.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/news/article/Trumbull-swim-teams-find-a-home-at-University-of-17417386.php" data-hdn-analytics="visit|article-17417386|-111568|3" data-epe-inst="s:0;t:75" data-epe-title="1">Trumbull swim teams find a home at University of Bridgeport</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Trumbull-Long-Hill-redevelopment-economy-17416051.php" data-hdn-analytics="visit-from-img|article-17416051|-111568|4">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/27/23/25/22885730/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/27/23/25/22885730/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/27/23/25/22885730/4/ratio1x1_100.jpg" alt="A sign near Franco Gianni's Pizza &amp; Restaurant on Broadway in Trumbull describes how the renovation of the Long Hill Green Village District has made the area more environmentally sustainable.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/news/article/Trumbull-Long-Hill-redevelopment-economy-17416051.php" data-hdn-analytics="visit|article-17416051|-111568|4" data-epe-inst="s:0;t:75" data-epe-title="1">Trumbull’s Long Hill revamp helps both economy and environment</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Photos-Trumbull-public-schools-reopen-for-the-17407880.php" data-hdn-analytics="visit-from-img|article-17407880|-111568|5">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/27/17/72/22871694/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/27/17/72/22871694/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/27/17/72/22871694/4/ratio1x1_100.jpg" alt="Speech pathologist Kaelyn Bonaventura shares a hug with a returning student during first day of school at Tashua Elementary School in Trumbull, Conn. on Tuesday, August 30, 2022.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/news/article/Photos-Trumbull-public-schools-reopen-for-the-17407880.php" data-hdn-analytics="visit|article-17407880|-111568|5" data-epe-inst="s:0;t:75" data-epe-title="1">Photos: Trumbull public schools reopen for the new school year</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Vacant-Trumbull-Board-of-Finance-seat-filled-17384719.php" data-hdn-analytics="visit-from-img|article-17384719|-111568|6">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/27/04/00/22822924/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/27/04/00/22822924/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/27/04/00/22822924/4/ratio1x1_100.jpg" alt="Justin Scheuble, RTC Executive Board member and Board of Finance Candidate, has been appointed to fill the chair on the Board of Finance, left vacant by long time town volunteer and elected official, Elaine Hammers.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/news/article/Vacant-Trumbull-Board-of-Finance-seat-filled-17384719.php" data-hdn-analytics="visit|article-17384719|-111568|6" data-epe-inst="s:0;t:75" data-epe-title="1">Vacant Trumbull Board of Finance seat filled</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Trumbull-hosts-10th-annual-First-Selectman-s-17374997.php" data-hdn-analytics="visit-from-img|article-17374997|-111568|7">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/27/00/24/22807836/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/27/00/24/22807836/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/27/00/24/22807836/4/ratio1x1_100.jpg" alt="Brian Keane, of Trumbull, celebrates as he sinks a put during the 10th annual First Selectman’s Golf Classic at Tashua Knolls Gold Course, in Trumbull, Conn. Aug. 15, 2022.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/news/article/Trumbull-hosts-10th-annual-First-Selectman-s-17374997.php" data-hdn-analytics="visit|article-17374997|-111568|7" data-epe-inst="s:0;t:75" data-epe-title="1">Trumbull hosts 10th annual First Selectman’s golf classic</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Trumbull-industrial-building-sold-for-4-4-million-17359865.php" data-hdn-analytics="visit-from-img|article-17359865|-111568|8">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/26/72/64/22785327/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/26/72/64/22785327/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/26/72/64/22785327/4/ratio1x1_100.jpg" alt="Norwalk's Avison Young has purchased a 57,234 square foot manufacturing building at 205 Spring Hill Road in Trumbull -- previously owned by Trumbull Printing -- on behalf of Shelbourne Global Solutions, LLC.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/news/article/Trumbull-industrial-building-sold-for-4-4-million-17359865.php" data-hdn-analytics="visit|article-17359865|-111568|8" data-epe-inst="s:0;t:75" data-epe-title="1">Trumbull industrial building sold for $4.4 million</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/What-makes-school-nurses-special-The-Trumbull-17359635.php" data-hdn-analytics="visit-from-img|article-17359635|-111568|9">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/26/72/57/22784998/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/26/72/57/22784998/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/26/72/57/22784998/4/ratio1x1_100.jpg" alt="School nurses Patty Gold, right, from Madison Middle School, and Jeanne Hoggatt, from Middlebrook School, wait to give out COVID-19 vaccinations during the vaccination clinic held for teachers and school staff in Trumbull, Conn. March 4, 2021.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/news/article/What-makes-school-nurses-special-The-Trumbull-17359635.php" data-hdn-analytics="visit|article-17359635|-111568|9" data-epe-inst="s:0;t:75" data-epe-title="1">Trumbull Health department hosts poster contest</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Trumbull-reminds-residents-about-new-districts-17340150.php" data-hdn-analytics="visit-from-img|article-17340150|-111568|10">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/22/44/73/21647098/10/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/22/44/73/21647098/10/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/22/44/73/21647098/10/ratio1x1_100.jpg" alt="Voters line up outside Madison Middle School before the polls open at 6 a.m. on Election Day, 2020.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/news/article/Trumbull-reminds-residents-about-new-districts-17340150.php" data-hdn-analytics="visit|article-17340150|-111568|10" data-epe-inst="s:0;t:75" data-epe-title="1">Trumbull reminds residents about new districts ahead of primaries</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                    </div>
                <div class="scrollSpacer"></div>
            </ul>
        </div>
        <button class="articleRibbon--nav-btn articleRibbon--nav-next fade show " data-delta="1" aria-label="Next"></button>
    </div>
        <script type="text/javascript">
        var nextStory = [
                                                            {
                    "id": 17441768,
                    "headline": "Trumbull school board backs naming band room after...",
                    "url": "/news/article/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php",
                    "image": "https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17434055,
                    "headline": "Survey: Trumbull residents want more trees, less...",
                    "url": "/news/article/Survey-Trumbull-residents-want-more-trees-less-17434055.php",
                    "image": "https://s.hdnux.com/photos/01/27/32/43/22915295/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17417386,
                    "headline": "Trumbull swim teams find a home at University of...",
                    "url": "/news/article/Trumbull-swim-teams-find-a-home-at-University-of-17417386.php",
                    "image": "https://s.hdnux.com/photos/01/27/23/70/22887950/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17416051,
                    "headline": "Trumbull’s Long Hill revamp helps both economy and...",
                    "url": "/news/article/Trumbull-Long-Hill-redevelopment-economy-17416051.php",
                    "image": "https://s.hdnux.com/photos/01/27/23/25/22885730/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17407880,
                    "headline": "Photos: Trumbull public schools reopen for the new...",
                    "url": "/news/article/Photos-Trumbull-public-schools-reopen-for-the-17407880.php",
                    "image": "https://s.hdnux.com/photos/01/27/17/72/22871694/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17384719,
                    "headline": "Vacant Trumbull Board of Finance seat filled",
                    "url": "/news/article/Vacant-Trumbull-Board-of-Finance-seat-filled-17384719.php",
                    "image": "https://s.hdnux.com/photos/01/27/04/00/22822924/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17374997,
                    "headline": "Trumbull hosts 10th annual First Selectman’s golf...",
                    "url": "/news/article/Trumbull-hosts-10th-annual-First-Selectman-s-17374997.php",
                    "image": "https://s.hdnux.com/photos/01/27/00/24/22807836/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17359865,
                    "headline": "Trumbull industrial building sold for $4.4 million",
                    "url": "/news/article/Trumbull-industrial-building-sold-for-4-4-million-17359865.php",
                    "image": "https://s.hdnux.com/photos/01/26/72/64/22785327/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17359635,
                    "headline": "Trumbull Health department hosts poster contest",
                    "url": "/news/article/What-makes-school-nurses-special-The-Trumbull-17359635.php",
                    "image": "https://s.hdnux.com/photos/01/26/72/57/22784998/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17340150,
                    "headline": "Trumbull reminds residents about new districts ahead...",
                    "url": "/news/article/Trumbull-reminds-residents-about-new-districts-17340150.php",
                    "image": "https://s.hdnux.com/photos/01/22/44/73/21647098/10/ratio3x2_100.jpg"
                }                    ];
    </script>
<!-- e design/collection/dynamic_ribbon_articles/single_zone.tpl --><!-- e hearst/collections/dynamic_ribbon_articles.tpl -->
</div><!-- e src/business/widgets/hearst/collection/widget.tpl --></section> <div class="belowMastheadWrapper"></div> <section id="content" class="article" data-type="dtc"><!-- hearst/article/articleHeader.tpl -->
            
            
    <header class="article--header articleHeader"><div class="articleHeader--breadcrumbs"><a class="articleHeader--breadcrumbs-item" href="https://www.trumbulltimes.com/news/">News</a></div><h1 class="articleHeader--headline" aria-labelledby="Trumbull school board supports naming band room for Peter Horton">'A no-brainer': Trumbull school board backs plan to name band room for late Peter Horton</h1><h3 class="articleHeader--deck">'Pete was an inspiration'</h3><div class="articleHeader--subHead hasPhoto"><div class="articleHeader--photo"><a href="https://www.trumbulltimes.com/author/amanda-cuda/" title="Amanda Cuda" class="articleHeaderHeader--subhead-img hdn-analytics" data-hdn-analytics="visit-from-image|Amanda Cuda-Author Page|articleHeader-header|1" target="_blank" rel="noopener noreferrer"><picture><source src="https://s.hdnux.com/photos/55/73/36/12040083/4/square_small.jpg 1x, https://s.hdnux.com/photos/55/73/36/12040083/4/square_medium.jpg 2x" media="(min-width: 20rem)"><img class="articleHeaderHeader--subhead-img" srcset="https://s.hdnux.com/photos/55/73/36/12040083/4/square_small.jpg" alt="Photo of Amanda Cuda"/></picture></a></div><div class="articleHeader--byline"><a href="https://www.trumbulltimes.com/author/amanda-cuda/" title="Amanda Cuda" class="articleHeader--byline-url hdn-analytics" data-hdn-analytics="visit|Amanda Cuda-Author Page|article-header|1" target="_blank" rel="noopener noreferrer">Amanda Cuda</a></div><div class="articleHeader--timestamp"><time class="articleHeader--timestamp-pubdate hasUpdate hidden-xs" datetime="2022-09-14 19:54:16">Sep. 14, 2022</time><time class="articleHeader--timestamp-update" datetime="2022-09-14 19:54:16">Updated: Sep. 14, 2022 5:36&nbsp;p.m.</time></div><div class="articleHeader--shareTools"><!-- hearst/common/shareTools.tpl -->
    
<div class="share-list comments">
    <a class="share-facebook" data-shareNetwork="facebook">Facebook</a>
    <a class="share-twitter" data-shareNetwork="twitter">Twitter</a>
    <a class="share-email" data-shareNetwork="email">Email</a>
            <div class="pipe"></div>
                    
                            <a class="share-comments" data-shareNetwork="comments" href="https://www.trumbulltimes.com/news/articleComments/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php" onclick="document.location.href = document.location.href.replace('/article/','/articleComments/').replace('/slideshow/','/slideshowComments/'); return false;">Comments</a>
        <span class="share-count"></span>
    </div>
<!-- e hearst/common/shareTools.tpl --></div></div></header>
<!-- e hearst/article/articleHeader.tpl --><!-- hearst/common/chapterNavigation.tpl -->
        <!-- e hearst/common/chapterNavigation.tpl --><article class="article--content"><section id="articleTop" class="article--content-zone top"></section>
                        <!-- hearst/article/content/gallery.tpl -->
<section class="gallery extendFromGrid" data-layout="default" data-total="3" data-guid="article_17441768_gallery" data-title="" aria-label="carousel" role="region">
    <p class="sr-only">This is a carousel. Use Next and Previous buttons to navigate</p>
    <div class="gallery--count expand">
        <div class="gallery--count-outer">
            <span aria-hidden="true">3</span>
        </div>
    </div>
    <div class="gallery--slider beginning">
         <button class="nav prev" aria-label="Previous"></button>
        <figure class="gallery--slider-item "style="z-index: 0;"id="1-image-22713481"data-slide-number='1'data-slide-id="22713481"role="group"aria-label="1 of 3">




























                <picture class="image" data-width="1575" data-height="1132" ><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1200.jpg" media="(min-width: 1292px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1150.jpg" media="(min-width: 1230px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1100.jpg" media="(min-width: 1168px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1050.jpg" media="(min-width: 1106px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1000.jpg" media="(min-width: 1044px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_950.jpg" media="(min-width: 982px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_900.jpg 1x, https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1800.jpg 2x" media="(min-width: 920px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_850.jpg 1x, https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1700.jpg 2x" media="(min-width: 858px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_800.jpg 1x, https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1600.jpg 2x" media="(min-width: 796px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_750.jpg 1x, https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1500.jpg 2x" media="(min-width: 734px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_700.jpg 1x, https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1400.jpg 2x" media="(min-width: 672px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_650.jpg 1x, https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1300.jpg 2x" media="(min-width: 610px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_600.jpg 1x, https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1200.jpg 2x" media="(min-width: 548px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_550.jpg 1x, https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1100.jpg 2x" media="(min-width: 486px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_500.jpg 1x, https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_1000.jpg 2x" media="(min-width: 424px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_450.jpg 1x, https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_900.jpg 2x" media="(min-width: 362px)"><source srcset="https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_400.jpg 1x, https://s.hdnux.com/photos/01/26/51/22/22713481/7/ratio3x2_800.jpg 2x" media="(min-width: 300px)"><img class="landscape cropped" src="https://s.hdnux.com/photos/01/26/51/22/22713481/7/1200x0.jpg" alt="Band director Peter Horton directs a rehearsal of the Trumbull High School Golden Eagle Marching Band on Wednesday, Nov. 16, 2016. "></picture><figcaption ><span class="count">1<span>of</span>3</span><span class="caption"><p>Band director Peter Horton directs a rehearsal of the Trumbull High School Golden Eagle Marching Band on Wednesday, Nov. 16, 2016. </p></span><span class="credits">Brian A. Pounds / Hearst Connecticut Media</span><span class="show-more" aria-hidden="true"><a href="#" onclick="return false;">Show More</a></span><span class="show-less" aria-hidden="true"><a href="#" onclick="return false;">Show Less</a></span></figcaption></figure><figure class="gallery--slider-item "style="z-index: 1; visibility:hidden"id="2-image-21701540"data-slide-number='2'data-slide-id="21701540"aria-hidden="true" tabindex="-1"role="group"aria-label="2 of 3">




























                <picture class="image" data-width="2048" data-height="1536" ><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1200.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_2400.jpg 2x" media="(min-width: 1292px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1150.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_2300.jpg 2x" media="(min-width: 1230px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1100.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_2200.jpg 2x" media="(min-width: 1168px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1050.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_2100.jpg 2x" media="(min-width: 1106px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1000.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_2000.jpg 2x" media="(min-width: 1044px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_950.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1900.jpg 2x" media="(min-width: 982px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_900.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1800.jpg 2x" media="(min-width: 920px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_850.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1700.jpg 2x" media="(min-width: 858px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_800.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1600.jpg 2x" media="(min-width: 796px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_750.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1500.jpg 2x" media="(min-width: 734px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_700.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1400.jpg 2x" media="(min-width: 672px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_650.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1300.jpg 2x" media="(min-width: 610px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_600.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1200.jpg 2x" media="(min-width: 548px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_550.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1100.jpg 2x" media="(min-width: 486px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_500.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_1000.jpg 2x" media="(min-width: 424px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_450.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_900.jpg 2x" media="(min-width: 362px)"><source srcset="https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_400.jpg 1x, https://s.hdnux.com/photos/01/22/62/16/21701540/4/ratio3x2_800.jpg 2x" media="(min-width: 300px)"><img class="landscape cropped" src="https://s.hdnux.com/photos/01/22/62/16/21701540/4/1200x0.jpg" alt="The Trumbull High School Golden Eagle Marching Band performs at the USBands’ National Championships at MetLife Stadium in East Rutherford, N.J. in this undated photo."></picture><figcaption  style="opacity: 0;" tabindex="-1"><span class="count">2<span>of</span>3</span><span class="caption"><p>The Trumbull High School Golden Eagle Marching Band performs at the USBands’ National Championships at MetLife Stadium in East Rutherford, N.J. in this undated photo.</p></span><span class="credits">Carminda Braz /Contributed /</span><span class="show-more" aria-hidden="true"><a href="#" onclick="return false;">Show More</a></span><span class="show-less" aria-hidden="true"><a href="#" onclick="return false;">Show Less</a></span></figcaption></figure><figure class="gallery--slider-item "style="z-index: 2; visibility:hidden"id="3-image-22711206"data-slide-number='3'data-slide-id="22711206"aria-hidden="true" tabindex="-1"role="group"aria-label="3 of 3">




























                <picture class="image" data-width="2048" data-height="1484" ><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1200.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_2400.jpg 2x" media="(min-width: 1292px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1150.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_2300.jpg 2x" media="(min-width: 1230px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1100.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_2200.jpg 2x" media="(min-width: 1168px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1050.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_2100.jpg 2x" media="(min-width: 1106px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1000.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_2000.jpg 2x" media="(min-width: 1044px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_950.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1900.jpg 2x" media="(min-width: 982px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_900.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1800.jpg 2x" media="(min-width: 920px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_850.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1700.jpg 2x" media="(min-width: 858px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_800.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1600.jpg 2x" media="(min-width: 796px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_750.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1500.jpg 2x" media="(min-width: 734px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_700.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1400.jpg 2x" media="(min-width: 672px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_650.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1300.jpg 2x" media="(min-width: 610px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_600.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1200.jpg 2x" media="(min-width: 548px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_550.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1100.jpg 2x" media="(min-width: 486px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_500.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_1000.jpg 2x" media="(min-width: 424px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_450.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_900.jpg 2x" media="(min-width: 362px)"><source srcset="https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_400.jpg 1x, https://s.hdnux.com/photos/01/26/50/56/22711206/7/ratio3x2_800.jpg 2x" media="(min-width: 300px)"><img class="landscape cropped" src="https://s.hdnux.com/photos/01/26/50/56/22711206/7/1200x0.jpg" alt="Trumbull High's &quot;Golden Eagles&quot; Marching Band Director Peter Horton poses during practice at the school in Trumbull, Conn., on Thursday Oct. 25, 2018. "></picture><figcaption  style="opacity: 0;" tabindex="-1"><span class="count">3<span>of</span>3</span><span class="caption"><p>Trumbull High's "Golden Eagles" Marching Band Director Peter Horton poses during practice at the school in Trumbull, Conn., on Thursday Oct. 25, 2018. </p></span><span class="credits">Christian Abraham / Hearst Connecticut Media</span><span class="show-more" aria-hidden="true"><a href="#" onclick="return false;">Show More</a></span><span class="show-less" aria-hidden="true"><a href="#" onclick="return false;">Show Less</a></span></figcaption></figure>
        <button class="nav next" aria-label="Next"></button>
    </div>
    <ul class="gallery--indicators fade show" data-current='1'>
        <li class="large" data-current='1' aria-label="Go to slide 1"><svg><circle cx="4" cy="4" r="4" fill="#adadad"/></svg></li><li class="large" aria-label="Go to slide 2"><svg><circle cx="4" cy="4" r="4" fill="#adadad"/></svg></li><li class="large" aria-label="Go to slide 3"><svg><circle cx="4" cy="4" r="4" fill="#adadad"/></svg></li>
    </ul>
         <style> .gallery--slider figure figcaption { margin: 0; } .gallery[data-guid="article_17441768_gallery"] .gallery--count::after, .gallery[data-guid="article_17441768_gallery"] .gallery--slider .nav, .gallery[data-guid="article_17441768_gallery"] .gallery--indicators, .gallery[data-guid="article_17441768_gallery"] .gallery--slider aside { z-index: 3; } </style> 
</section>
<!-- e hearst/article/content/gallery.tpl -->            
    <!-- Missed: ad -->

            <p>TRUMBULL — In the four years Amy Lafond spent as a student of Peter Horton, she never stopped being in awe of him.</p>
    
            <p>Horton, <a href="https://www.ctinsider.com/news/article/Former-Trumbull-High-School-marching-band-17311152.php">who died in July</a>, was the director of Trumbull High School's Golden Eagle Marching Band. He taught music for 30 years until his retirement in 2020. In that time, he influenced countless students, including Lafond, who was a student of his from 1989 to 1993. She also served as a drum major in the band from 1991 to 1993.</p>
    <div id="paywall" class="content-wrapper">
            <p>Lafond said, when Horton conducted, it was as though his hands were creating music out of thin air.</p>
    
    <!-- hearst/article/content/embed.tpl -->
        <section class="article--content-embed inline-iframe" data-eid="item-96903">
                        <div id="c02bd118-6026-45e6-80f5-169124e96bb5" class="hst-exco-player"></div><script>
(function (d, id) {
  var js, fjs = d.getElementsByTagName('script')[0];
  js = d.createElement('script');
  js.id = 'exco';
  js.dataset.src = 'https://player.ex.co/player/' + id;
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'c02bd118-6026-45e6-80f5-169124e96bb5'));
</script><!-- amp-exco-d0292dde-5a56-4372-9726-860ed0fe461e -->

            </section>
<!-- e hearst/article/content/embed.tpl -->
            <p>"Pete was an inspiration," she said. "Watching him conduct was the reason why I became a music teacher. It’s like having a superpower."</p>
    
            <p>Lafond was part of a committee that met recently to discuss naming the band room at Trumbull High School after Horton. She and other committee members spoke at Tuesday's Trumbull Board of Education meeting and presented their findings.</p>
    
    <!-- Missed: ad -->

            <p>All who spoke talked about Horton's enthusiasm for music, including current band student Lianna Weaver. Weaver, who is also Horton's granddaughter, said she remembers watching Horton work when she was an elementary or middle school student who parked outside the band room, waiting for Horton to finish up.</p>
    
    <!-- Missed: ad -->

            <p>"I saw him constantly working with (the students), constantly teaching them," she said. "I saw his passion." </p>
    
            <p>Assistant Superintendent of Schools Susan Iwanicki explained that the committee had come up with three potential names for the band room: "The Peter G. Horton Band Room, Pride – Attitude – Concentration 'From the Heart'"; "The Peter G. Horton Band Room 'From the Heart!' Pride – Attitude – Concentration"; "The Peter G. Horton Band Room 'Play From the Heart!'"</p>
    
    <!-- Missed: ad -->

            <p>All the potential names incorporated some version of phrases Horton commonly used.</p>
    
            <p>Board of Education chair Lucinda Timpanelli said, given that Horton was such a beloved figure in the community, naming the band room for him was "a no-brainer."</p>
    
            <p>"I worked with Peter," she said. "He was a good man, always a good man."</p>
    <aside class="article--content-inline"><aside class="zone">
    
<!-- hearst/home/mostPopular.tpl -->

    <div class="mostPopular">
        <h2 class="collectionHeader" role="heading" aria-level="2">Most Popular</h2>
                                                <ol class="mostPopular--list">
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/business/article/Regulators-fine-electric-supplier-17436475.php" title="Company fined $1 million by CT officials, license revoked" data-hdn-analytics="visit|article-17436475|most_popular|0">Company fined $1 million by CT officials, license revoked</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Stratford-restaurant-owners-bring-Italian-flavor-17442060.php" title="Stratford restaurant owners bring Italian flavor to Milford" data-hdn-analytics="visit|article-17442060|most_popular|1">Stratford restaurant owners bring Italian flavor to Milford</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php" title="'A no-brainer': Trumbull school board backs plan to name band room for late Peter Horton" data-hdn-analytics="visit|article-17441768|most_popular|2">'A no-brainer': Trumbull school board backs plan to name band room for late Peter Horton</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Former-High-Sheriff-of-Fairfield-County-17438553.php" title="Former 'High Sheriff' of Fairfield County, imprisoned for car-towing scheme, wins state pardon" data-hdn-analytics="visit|article-17438553|most_popular|3">Former 'High Sheriff' of Fairfield County, imprisoned for car-towing scheme, wins state pardon</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Volunteers-needed-to-help-clean-up-Trumbull-Sunday-17438807.php" title="Volunteers needed to help clean up Trumbull Sunday" data-hdn-analytics="visit|article-17438807|most_popular|4">Volunteers needed to help clean up Trumbull Sunday</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/US-news-college-rankings-2023-ct-17435708.php" title="Connecticut colleges make U.S. News & World Report’s new ranking of best schools" data-hdn-analytics="visit|article-17435708|most_popular|5">Connecticut colleges make U.S. News & World Report’s new ranking of best schools</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Trumbull-location-of-Fryborg-delayed-but-17182071.php" title="Trumbull location of Fryborg delayed — but it’s coming" data-hdn-analytics="visit|article-17182071|most_popular|6">Trumbull location of Fryborg delayed — but it’s coming</a>
                                                    </li>
                                    </ol>
                        </div>
<!--e hearst/home/mostPopular.tpl --></aside></aside>
            <p>Timpanelli said her preference for the room name was the "Play From the Heart" option, as that's the expression she most associated with him. </p>
    
            <p>Ultimately, that option was the one that got the most support from the board, with five members for it.</p>
    
            <p>Board member Jackie Norcel asked if the words "Pride – Attitude – Concentration" could be added to that name, and Lafond said it's something the committee would consider, and bring their thought back to the board.</p>
    
            <p>Eventually, the board voted to recommend naming the room "The Peter G. Horton Band Room 'Play From the Heart!' " and adding the words  "Pride – Attitude – Concentration."</p>
    
            <p>In her presentation, Lafond emphasized that renaming the room for Horton was important given the impact he had.</p>
    
            <p>"I just hope that, 30 years from now, I have a student who will get up and speak about me the way I’ve heard so many people speak about Pete," she said.</p>
    
            <p> </p>
    <section id="articleBottom" class="article--content-zone bottom"></section></div></article><!-- hearst/article/articleAside.tpl -->
<aside class="article--aside slideshow--aside">
    <aside id="zoneD" class="zone">    
                        <!-- business/templates/design/item/default.tpl -->
    <!-- mid:freeform.85203 -->
    <div class="hst-freeform hdnce-e hdnce-item-85203">
                <script type="text/javascript" id="taboola-right-rail-script-id">
(function () {
    window._taboolaRRI = window._taboolaRRI || 0;
    window._taboolaRRI++;
    var e = document.documentElement;
    var g = document.getElementsByTagName('body')[0];
    var w = window.innerWidth||e.clientWidth||g.clientWidth;
    if ( (w >= 768 && window._taboolaRRI === 1) || (w < 768 && window._taboolaRRI === 2) ){
        var c = 'taboola-right-rail-thumbnails';
        var p = 'Right Rail Thumbnails';
        var m = 'rr';
        try {
            if (window._taboolaNetworkMode) {
                c = c + '---redesign';
                p = p + ' - Redesign';
                if (HDN.dataLayer.content.objectType  === 'article') {
                    m = 'f';
                if (HDN.dataLayer.presentation.infiniteScrollEnabled && (window.infiniteScroll && window.infiniteScroll.length > 0) && HDN.dataLayer.content.objectId && window.Article.isSensitive !== true && (Object.hasOwnProperty.call(HDN, 'activeABTest') && HDN.activeABTest === 'ENG9746')) {
                    p = 'Right Rail Thumbnails';
                    m = '1x8-rr';
                }
                }
            }
        } catch (e) {}
        var d = document.createElement('div');
        d.id = c;
        var s = document.getElementById('taboola-right-rail-script-id');
        s.parentNode.insertBefore(d, s);
        window._taboola = window._taboola || [];
        _taboola.push({
            mode: 'thumbnails-' + m,
            container: c,
            placement: p,
            target_type: 'mix'
        });
    }
})();
</script>
    </div>
            </aside>
    <aside id="zoneC" class="zone">
    
<!-- hearst/home/mostPopular.tpl -->

    <div class="mostPopular">
        <h2 class="collectionHeader" role="heading" aria-level="2">Most Popular</h2>
                                                <ol class="mostPopular--list">
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/business/article/Regulators-fine-electric-supplier-17436475.php" title="Company fined $1 million by CT officials, license revoked" data-hdn-analytics="visit|article-17436475|most_popular|0">Company fined $1 million by CT officials, license revoked</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Stratford-restaurant-owners-bring-Italian-flavor-17442060.php" title="Stratford restaurant owners bring Italian flavor to Milford" data-hdn-analytics="visit|article-17442060|most_popular|1">Stratford restaurant owners bring Italian flavor to Milford</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php" title="'A no-brainer': Trumbull school board backs plan to name band room for late Peter Horton" data-hdn-analytics="visit|article-17441768|most_popular|2">'A no-brainer': Trumbull school board backs plan to name band room for late Peter Horton</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Former-High-Sheriff-of-Fairfield-County-17438553.php" title="Former 'High Sheriff' of Fairfield County, imprisoned for car-towing scheme, wins state pardon" data-hdn-analytics="visit|article-17438553|most_popular|3">Former 'High Sheriff' of Fairfield County, imprisoned for car-towing scheme, wins state pardon</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Volunteers-needed-to-help-clean-up-Trumbull-Sunday-17438807.php" title="Volunteers needed to help clean up Trumbull Sunday" data-hdn-analytics="visit|article-17438807|most_popular|4">Volunteers needed to help clean up Trumbull Sunday</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/US-news-college-rankings-2023-ct-17435708.php" title="Connecticut colleges make U.S. News & World Report’s new ranking of best schools" data-hdn-analytics="visit|article-17435708|most_popular|5">Connecticut colleges make U.S. News & World Report’s new ranking of best schools</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Trumbull-location-of-Fryborg-delayed-but-17182071.php" title="Trumbull location of Fryborg delayed — but it’s coming" data-hdn-analytics="visit|article-17182071|most_popular|6">Trumbull location of Fryborg delayed — but it’s coming</a>
                                                    </li>
                                    </ol>
                        </div>
<!--e hearst/home/mostPopular.tpl --></aside>
</aside>
<!-- e hearst/article/articleAside.tpl --><!-- hearst/article/articleFooter.tpl -->
<footer class="article--footer"><!-- hearst/common/author_body.tpl -->
     
        <div class="articleFooter">
                                <div class="articleFooter--author">
                                    <a href="https://www.trumbulltimes.com/author/amanda-cuda/" title="Amanda Cuda" class="articleFooter--author-image hdn-analytics" data-hdn-analytics="visit-from-image|Amanda Cuda-Author Page|article-footer|1" target="_blank" rel="noopener noreferrer">
                    <picture>
                        <source srcset="https://s.hdnux.com/photos/55/73/36/12040083/4/square_small.jpg 1x, https://s.hdnux.com/photos/55/73/36/12040083/4/square_medium.jpg 2x" media="(min-width: 20rem)">
                        <img class="articleFooter--subhead-img" src="https://s.hdnux.com/photos/55/73/36/12040083/4/square_small.jpg" alt="Photo of Amanda Cuda"/>
                    </picture>
                </a>
                            <div class="articleFooter--author-label">Written By </div>                    <a href="https://www.trumbulltimes.com/author/amanda-cuda/" title="Amanda Cuda" class="articleFooter--author-name hdn-analytics" data-hdn-analytics="visit|Amanda Cuda-Author Page|article-footer|1" target="_blank" rel="noopener noreferrer">Amanda Cuda</a>
                </div>
                    <div class="articleFooter--author articleFooter--social">
                <div class="articleFooter--social-label">Reach Amanda on</div>
                                <a class="articleFooter--social-twitter" href="https://twitter.com/AmandaCuda"></a>                            </div>
                <div class="articleFooter--bio"><p>Though she grew up in Michigan, Amanda Cuda is from Connecticut originally and moved here shortly after graduating from Michigan State University. She has worked for the Connecticut Post in a variety positions, including town reporter, features writer, TV columnist and health editor. She's a married mother of twins who loves reading, watching TV and rooting for the Michigan State Spartans.
</p></div>    </div>
<!-- e hearst/common/author_body.tpl --><section class="article--comments"><button id="commentsButton" data-link="https://www.trumbulltimes.com/news/articleComments/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php" onclick="document.location.href = 'https://www.trumbulltimes.com/news/articleComments/Trumbull-Board-of-Education-Peter-Horton-band-17441768.php'; return false;">View Comments</button></section></footer>
<!-- e hearst/article/articleFooter.tpl --></section><section id="bottomZone" class="zone bottomZone lock">    
                        <!-- business/templates/design/item/default.tpl -->
    <!-- mid:freeform.85204 -->
    <div class="hst-freeform hdnce-e hdnce-item-85204">
                <script type="text/javascript" id="taboola-feed-script-id">
(function () {
    var c = 'taboola-below-article-thumbnails';
    var p = 'Below Article Thumbnails';
    try {
        if (window._taboolaNetworkMode) {
            var e = document.documentElement;
            var g = document.getElementsByTagName('body')[0];
            var w = window.innerWidth||e.clientWidth||g.clientWidth;
            if (w < 768) {
                c = 'taboola-mobile-below-article-feed---redesign';
                p = 'Mobile Below Article Feed - Redesign';
            } else {
                c = 'taboola-below-article-feed---redesign';
                p = 'Below Article Feed - Redesign';
            }
        }
    } catch (e) {}
    var d = document.createElement('div');
    d.id = c;
    var s = document.getElementById('taboola-feed-script-id');
    s.parentNode.insertBefore(d, s);
    window._taboola = window._taboola || [];
    window._taboola.push({
        mode: 'thumbnails-a',
        container: c,
        placement: p,
        target_type: 'mix'
    });
})();
</script>
    </div>
            <div class="taboola-skip-wrapper"><div id="taboola-skip"></div></div></section></main><!-- hearst/common/siteFooter.tpl -->
    <footer class="pageFooter">
    <div class="lock">
        <div class="pageFooter--wrapper">
            <div class="pageFooter--left">
                <a href="/">
                    <img class="pageFooter--left-logo" src="/img/logos/black/logo.svg" alt="Trumbull Times Homepage - Site Logo">
                </a>
                <ul class="pageFooter--left-social">
                    <li class="facebook"><a href="http://facebook.com/trumbulltimes" aria-label="facebook"></a></li>                    <li class="twitter"><a href="http://twitter.com/trumbulltimes" aria-label="twitter"></a></li>                                                        </ul>
            </div>
            <div class="pageFooter--right">
                <div class="pageFooter--right-topLine">
                    <a href="#content" class="return"><span class="full">Return to</span> Top</a>
                </div>
                <div class="pageFooter--right-links">
                    
                    <!-- hearst/item/standalone.tpl -->
<div class="hdnce-e hdnce-item-97500"><!-- mid:freeform.97500 -->
<style>
@media (min-width: 768px) {
  .pageFooter--right-links .wrapper > li:nth-child(2) {
    box-sizing: border-box;
    padding-left: 50px;
  }
}
</style>
<ul class="wrapper" role="presentation">
  <li>
<div class="title" role="heading" aria-level="2">About</div>
    <ul class="section" role="presentation">
      <li><a href="/home/article/How-Hearst-Newspapers-is-delivering-information-15678014.php">Newspaper Delivery Safety Procedures</a></li>
      <li><a href="/privacy/">Privacy Notice</a></li>
      <li><a href="/privacy/#additionalinformationforcaliforniaresidents">Your California Privacy Rights</a></li>
      <li><a href="/privacy/#interestbasedads">Interest Based Ads</a></li>
      <li><a href="/tos/">Terms of Use</a></li>
      <li><a href="https://eevd.fa.us6.oraclecloud.com/hcmUI/CandidateExperience/en/sites/CX_11004">Careers</a></li>
      <li><a href="https://hearstmediact.com/">Advertising</a></li>
    </ul>
  </li>
  <li>
<div class="title" role="heading" aria-level="2">Contact</div>
    <ul class="section" role="presentation">
      <li><a href="/contact/">Contact Us</a></li>
      <li><a href="/help/">Help</a></li>
      <li><a href="https://subscription.hearstmediact.com/eEdition?siteID=CT_TT">E-Edition</a></li>
      <li><a href="/submissions/">Submissions</a></li>
    </ul>
  </li>
  <li>
<div class="title" role="heading" aria-level="2">Connect</div>
    <ul class="section" role="presentation">
      <li><a href="https://subscription.hearstmediact.com/checkout/700/1486?siteid=CT_TT&amp;origin=subserv&amp;ipid=footer">Subscribe Today</a></li>
      <li><a href="https://www.facebook.com/trumbulltimes">Facebook</a></li>
      <li><a href="https://twitter.com/trumbulltimes">Twitter</a></li>
    </ul>
  </li>
  <li>
</li>
</ul>
</div><!-- / hdnce-e -->                </div>
            </div>
        </div>
        <div class="pageFooter--branding">
            <img class="pageFooter--branding-logo" src="/img/core/hearst_newspapers_logo.svg" alt="HEARST newspapers logo" />
            <span class="pageFooter--branding-copyright">&copy;2022 Hearst</span>
        </div>
    </div>
                        <!-- hearst/common/spotImFooterJS.tpl -->
<script>
                                
        if ( document.readyState === "complete" || (document.readyState !== "loading" && !document.documentElement.doScroll)) {
            if (HDN && HDN.hasOwnProperty('spotim')) {
                HDN.spotim.commentCount(undefined,undefined,1);
            }
        } else {
            document.addEventListener("DOMContentLoaded", function() { 
                        if (HDN && HDN.hasOwnProperty('spotim')) {
                            HDN.spotim.commentCount(undefined,undefined,1);
                        }
                    });
        }
    
</script>
<!-- e hearst/common/spotImFooterJS.tpl -->
                            
                <script type="text/javascript">
                    window._taboola = window._taboola || [];
                    _taboola.push({flush: true});
                </script>
            
                    </footer>
<!-- e hearst/common/siteFooter.tpl -->
<!-- e hearst/article/types/dynamic_two_column.tpl --><!-- e design/article/dynamic_two_column.tpl -->                            </body>
</html>
<!-- e hearst/article/articleMain.tpl --><!-- e hearst/article/article_main.tpl -->