<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" xml:lang="en-US">
    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <title>
           Scales &amp; friends will bring the magic on March 18 | Trumbull Times     
</title>
        <link rel="profile" href="http://gmpg.org/xfn/11" />
        <link rel="shortcut icon" href="http://trumbulltimes.hanewsmedia.com/wp-content/uploads/sites/32/2015/09/TT-favicon.png" type="image/x-icon" />		<link rel="stylesheet" href="http://www.trumbulltimes.com/wp-content/themes/unspoken-tt/style.css" type="text/css" media="all" />
		<link rel="stylesheet" href="http://www.trumbulltimes.com/wp-content/themes/unspoken-tt/lib/js/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="all" />
        <link rel="pingback" href="http://www.trumbulltimes.com/xmlrpc.php" />
        <link rel="alternate" type="text/xml" title="RSS .92" href="http://www.trumbulltimes.com/feed/rss/"/>
        
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="http://www.trumbulltimes.com/feed/atom/" />
		<!--[if lt IE 8]><link rel="stylesheet" href="http://www.trumbulltimes.com/wp-content/themes/unspoken-tt/ie.css" type="text/css" media="all" /><![endif]-->

        
        
        <link rel="canonical" href="http://arts.hersamacorn.com/2017/03/16/scales-friends-will-bring-the-magic-on-march-18/" />

<!-- This site is optimized with the Yoast SEO Premium plugin v2.3.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Steve Scales is organizing Magic Moments Live for the Kennedy Center&#039;s Autism Project. by Keith Loria — Music fans know Steve Scales as the percussionist e"/>
<link rel="publisher" href="https://plus.google.com/+TrumbullTimesCT/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Scales &amp; friends will bring the magic on March 18 | Trumbull Times" />
<meta property="og:description" content="Steve Scales is organizing Magic Moments Live for the Kennedy Center&#039;s Autism Project. by Keith Loria — Music fans know Steve Scales as the percussionist e" />
<meta property="og:site_name" content="Trumbull Times" />
<meta property="article:publisher" content="https://www.facebook.com/TrumbullTimes" />
<meta property="article:tag" content="Magic Moments" />
<meta property="article:tag" content="Steve Scales" />
<meta property="article:section" content="Arts &amp; Leisure Features" />
<meta property="article:published_time" content="2017-03-16T11:13:06+00:00" />
<meta property="og:image" content="http://trumbulltimes.hanewsmedia.com/wp-content/uploads/sites/32/2017/03/cov-SteveScales-LEAD-PIC-3-16.jpg" />
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:description" content="Steve Scales is organizing Magic Moments Live for the Kennedy Center&#039;s Autism Project. by Keith Loria — Music fans know Steve Scales as the percussionist e"/>
<meta name="twitter:title" content="Scales &amp; friends will bring the magic on March 18 | Trumbull Times"/>
<meta name="twitter:site" content="@trumbulltimes"/>
<meta name="twitter:domain" content="Trumbull Times"/>
<meta name="twitter:image:src" content="http://trumbulltimes.hanewsmedia.com/wp-content/uploads/sites/32/2017/03/cov-SteveScales-LEAD-PIC-3-16.jpg"/>
<meta name="twitter:creator" content="@trumbulltimes"/>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//trumbulltimes.hanewsmedia.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//platform.linkedin.com' />
<link rel='dns-prefetch' href='//www.trumbulltimes.com' />
<link rel='dns-prefetch' href='//p.jwpcdn.com' />
<link rel='dns-prefetch' href='//cdn.datatables.net' />
<link rel='dns-prefetch' href='//cdn.rawgit.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Trumbull Times &raquo; Feed" href="http://www.trumbulltimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Trumbull Times &raquo; Comments Feed" href="http://www.trumbulltimes.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Trumbull Times &raquo; iCal Feed" href="http://www.trumbulltimes.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Trumbull Times &raquo; Scales &#038; friends will bring the magic on March 18 Comments Feed" href="http://www.trumbulltimes.com/65854/scales-friends-will-bring-the-magic-on-march-18/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.trumbulltimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=f23620b5541c963ee00661d915038a42"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='http://www.trumbulltimes.com/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='scap.flashblock-css'  href='http://trumbulltimes.hanewsmedia.com/wp-content/plugins/compact-wp-audio-player/css/flashblock.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='scap.player-css'  href='http://trumbulltimes.hanewsmedia.com/wp-content/plugins/compact-wp-audio-player/css/player.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='tfg_style-css'  href='http://www.trumbulltimes.com/wp-content/plugins/twitter-facebook-google-plusone-share/tfg_style.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='advpsStyleSheet-css'  href='http://trumbulltimes.hanewsmedia.com/wp-content/plugins/advanced-post-slider/advps-style.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-datatables-css'  href='//cdn.datatables.net/1.10.12/css/jquery.dataTables.min.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-buttons-css'  href='//cdn.datatables.net/buttons/1.2.1/css/buttons.dataTables.min.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-select-css'  href='//cdn.datatables.net/select/1.2.0/css/select.dataTables.min.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-fixedheader-css'  href='//cdn.datatables.net/fixedheader/3.1.2/css/fixedHeader.dataTables.min.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-fixedcolumns-css'  href='//cdn.datatables.net/fixedcolumns/3.2.2/css/fixedColumns.dataTables.min.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-responsive-css'  href='//cdn.datatables.net/responsive/2.1.0/css/responsive.dataTables.min.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='ce_responsive-css'  href='http://www.trumbulltimes.com/wp-content/plugins/simple-embed-code/css/video-container.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='cpsh-shortcodes-css'  href='http://trumbulltimes.hanewsmedia.com/wp-content/plugins/column-shortcodes/assets/css/shortcodes.css?ver=0.6.9' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css'  href='http://www.trumbulltimes.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='__disptype__-css'  href='http://www.trumbulltimes.com/wp-content/plugins/youtube-embed-plus/scripts/lity.min.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-animate-min-css-css'  href='http://trumbulltimes.hanewsmedia.com/wp-content/plugins/popover/css/animate.min.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.trumbulltimes.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.6' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var tribe_events_linked_posts = {"post_types":{"tribe_venue":"venue","tribe_organizer":"organizer"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://trumbulltimes.hanewsmedia.com/wp-content/plugins/compact-wp-audio-player/js/soundmanager2-nodebug-jsmin.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/themes/unspoken-tt/lib/js/jcarousellite_1.0.1_mod.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/themes/unspoken-tt/lib/js/fancybox/jquery.fancybox-1.3.4.pack.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/themes/unspoken-tt/lib/js/scripts.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/themes/unspoken-tt/lib/js/jquery.infinitescroll.init.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://p.jwpcdn.com/6/12/jwplayer.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://trumbulltimes.hanewsmedia.com/wp-content/plugins/advanced-post-slider/js/advps.frnt.script.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://trumbulltimes.hanewsmedia.com/wp-content/plugins/advanced-post-slider/bxslider/jquery.bxslider.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//cdn.datatables.net/1.10.12/js/jquery.dataTables.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.2.1/js/dataTables.buttons.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.2.1/js/buttons.colVis.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.2.1/js/buttons.print.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//cdn.rawgit.com/bpampuch/pdfmake/0.1.18/build/pdfmake.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//cdn.rawgit.com/bpampuch/pdfmake/0.1.18/build/vfs_fonts.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/jszip/2.5.0/jszip.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.2.1/js/buttons.html5.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//cdn.datatables.net/select/1.2.0/js/dataTables.select.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//cdn.datatables.net/fixedheader/3.1.2/js/dataTables.fixedHeader.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//cdn.datatables.net/fixedcolumns/3.2.2/js/dataTables.fixedColumns.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//cdn.datatables.net/responsive/2.1.0/js/dataTables.responsive.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var igsv_plugin_vars = {"lang_dir":"http:\/\/www.trumbulltimes.com\/wp-content\/plugins\/inline-google-spreadsheet-viewer\/languages","datatables_classes":".igsv-table:not(.no-datatables)","datatables_defaults_object":{"dom":"B<'clear'>lfrtip","buttons":["colvis","copy","csv","excel","pdf","print"]}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/plugins/inline-google-spreadsheet-viewer/igsv-datatables.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='//www.google.com/jsapi?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/plugins/inline-google-spreadsheet-viewer/igsv-gvizcharts.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/plugins/youtube-embed-plus/scripts/lity.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"http:\/\/www.trumbulltimes.com\/wp-admin\/admin-ajax.php","security":"62528a65c8","gallery_scrolloffset":"20","eppathtoscripts":"http:\/\/www.trumbulltimes.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","epresponsiveselector":"[\"iframe[src*='youtube.com']\",\"iframe[src*='youtube-nocookie.com']\",\"iframe[data-ep-src*='youtube.com']\",\"iframe[data-ep-src*='youtube-nocookie.com']\",\"iframe[data-ep-gallerysrc*='youtube.com']\"]","epdovol":"1","version":"11.5","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<link rel='https://api.w.org/' href='http://www.trumbulltimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.trumbulltimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.trumbulltimes.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://bit.ly/2ndY9eN' />
<link rel="alternate" type="application/json+oembed" href="http://www.trumbulltimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.trumbulltimes.com%2F65854%2Fscales-friends-will-bring-the-magic-on-march-18%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.trumbulltimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.trumbulltimes.com%2F65854%2Fscales-friends-will-bring-the-magic-on-march-18%2F&#038;format=xml" />
<script type="text/javascript">jwplayer.defaults = { "ph": 2 };</script>

<!-- Facebook Like Thumbnail -->
<link rel="image_src" href="http://trumbulltimes.hanewsmedia.com/wp-content/uploads/sites/32/2017/03/cov-SteveScales-LEAD-PIC-3-16.jpg" />
<!-- End Facebook Like Thumbnail -->

<link rel="alternate" type="application/rss+xml" title="Trumbull Times GeoRSS-Feed" href="http://trumbulltimes.hanewsmedia.com/wp-content/plugins/leaflet-maps-marker/leaflet-georss.php?layer=all" />
<style type='text/css' id='Responsive_Column_Widgets_1.2.6' >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</style>
<style type="text/css" id="style_custom_responsive_column_widgets_31161ac05099cfce8383f2e2623a45ec">.responsive_column_widgets { display: inline-block; width: 100%; }</style>
<style type='text/css' class='style_responsive_column_widgets_31161ac05099cfce8383f2e2623a45ec'>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</style><meta property="og:image" content="http://trumbulltimes.hanewsmedia.com/wp-content/uploads/sites/32/2017/03/cov-SteveScales-LEAD-PIC-3-16-150x150.jpg" /><a href="https://plus.google.com/+TrumbullTimesCT" rel="publisher" />

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/18392239/TrumbullTimes-KristineLilly-Rectangle', [300, 75], 'div-gpt-ad-1357320716616-0').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimes-KristineLilly-Square1', [300, 250], 'div-gpt-ad-1357320716616-1').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimes-KristineLilly-Square2', [300, 250], 'div-gpt-ad-1357320716616-2').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimes-KristineLilly-Square3', [300, 250], 'div-gpt-ad-1357320716616-3').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesEarLeft', [180, 90], 'div-gpt-ad-1357320716616-4').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesEarRight', [180, 90], 'div-gpt-ad-1357320716616-5').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesRectangle1', [300, 75], 'div-gpt-ad-1357320716616-6').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesRectangle2', [300, 75], 'div-gpt-ad-1357320716616-7').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesRectangle3', [300, 75], 'div-gpt-ad-1357320716616-8').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesSquare1', [300, 250], 'div-gpt-ad-1357320716616-9').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesSquare2', [300, 250], 'div-gpt-ad-1357320716616-10').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesSquare3', [300, 250], 'div-gpt-ad-1357320716616-11').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesSquare4', [300, 250], 'div-gpt-ad-1357320716616-12').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesNavBar', [728, 90], 'div-gpt-ad-1357320716616-13').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesLocalYokelSquare', [300, 250], 'div-gpt-ad-1357320716616-14').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesSquare5', [300, 250], 'div-gpt-ad-1357320716616-15').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesLocalYokelSpecial', [300, 250], 'div-gpt-ad-1357320716616-17').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesSplashAd', [600, 240], 'div-gpt-ad-1357320716616-16').addService(googletag.pubads());
googletag.defineSlot('/18392239/TrumbullTimesLargeSplash', [740, 510], 'div-gpt-ad-1448031815686-21').addService(googletag.pubads());

googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {

googletag.defineSlot('/18392239/TrumbullTimesSplashAd', [600, 240], 'div-gpt-ad-1357320716616-16').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script><style type="text/css">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</style>  

   
	</head>
	<body class="post-template-default single single-post postid-65854 single-format-standard tribe-bar-is-disabled">

        <div class="wrapper">
        
                         <div class="top-content-adplace">
                    <div id="execphp-10" class="widget_execphp">			<div class="execphpwidget"><!-- TrumbullTimesNavBar -->
<div id='div-gpt-ad-1357320716616-13' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1357320716616-13'); });
</script>
</div></div>
		</div>                </div>
                                
            <div class="header">
                <div class="header-meta">

                    <div id="top-menu" class="menu-top-menu-container"><ul id="menu-top-menu" class="header-menu clear"><li id="menu-item-31531" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-31531"><a href="http://www.trumbulltimes.com">Home</a></li>
<li id="menu-item-30435" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30435"><a target="_blank" href="https://classadz.vdata.com/HersamAcornCirc/SelectOption.aspx">Subscribe</a></li>
<li id="menu-item-31990" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31990"><a target="_blank" href="http://trumbulltimes.ct.newsmemory.com/">E-Edition</a></li>
<li id="menu-item-30438" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30438"><a target="_blank" href="http://trumbulltimes.ct.newsmemory.com/marketplace.php">Marketplace</a></li>
<li id="menu-item-31993" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31993"><a href="http://vermontnews-guide.com/">Visit Vermont</a></li>
<li id="menu-item-29085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29085"><a href="http://www.trumbulltimes.com/sign-up-for-email-alerts/">Sign Up for Email Alerts</a></li>
<li id="menu-item-30436" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-30436"><a href="http://#">Print Edition</a>
<ul class="sub-menu">
	<li id="menu-item-30495" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30495"><a href="http://www.trumbulltimes.com/newsstand-locations/">Newsstand Locations</a></li>
	<li id="menu-item-30437" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30437"><a target="_blank" href="https://classadz.vdata.com/HersamAcornCirc/SelectOption.aspx">Delivery Problems</a></li>
</ul>
</li>
<li id="menu-item-30439" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30439"><a target="_blank" href="http://www.hersamacorn.com/newspaper-advertising/">Advertise</a></li>
<li id="menu-item-31675" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children parent menu-item-31675"><a href="http://www.trumbulltimes.com/help/">Help</a>
<ul class="sub-menu">
	<li id="menu-item-31676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31676"><a href="http://www.trumbulltimes.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-31685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31685"><a href="http://www.trumbulltimes.com/about-us/">About Us</a></li>
	<li id="menu-item-31686" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31686"><a href="http://www.trumbulltimes.com/news-submission-guidelines/">News Submission Guidelines</a></li>
	<li id="menu-item-31568" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31568"><a href="http://www.trumbulltimes.com/submissions/">Submissions</a></li>
</ul>
</li>
</ul></div>
                    <div class="header-searchform">
                        <form method="get" action="http://www.trumbulltimes.com">
                            <fieldset>
                                <input type="text" id="s" name="s" onfocus="if(this.value=='Search') this.value='';" onblur="if(this.value=='') this.value='Search';" value="Search" />
                                <button type="submit"></button>
                            </fieldset>
                        </form>
                    </div>
                </div>
                <div class="header-middle clear">
                
                <div class="header-adplace-left">
                        <div id="header-adplace-left">			<div class="execphpwidget"><!-- TrumbullTimesEarLeft -->
<div id='div-gpt-ad-1357320716616-4' style='width:180px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1357320716616-4'); });
</script>
</div></div>
		</div>                    </div>
                    <div class="logo-header ">
                        <a href="http://www.trumbulltimes.com">
                        <img src="http://trumbulltimes.hanewsmedia.com/wp-content/uploads/sites/32/2015/09/TT-MAST-405.png" alt="Trumbull Times"/>                        </a>
                    </div>
                    <div class="header-adplace-right">
                        <div id="header-adplace-right">			<div class="execphpwidget"><!-- TrumbullTimesEarRight -->
<div id='div-gpt-ad-1357320716616-5' style='width:180px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1357320716616-5'); });
</script>
</div></div>
		</div>                      
                    </div>
                </div>
            </div>

						<div id="navigation" class="menu-navigation clear"><ul id="menu-navigation" class="menu"><li id="menu-item-30323" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-30323"><a href="http://www.trumbulltimes.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-30416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30416"><a href="http://www.trumbulltimes.com/category/news/police-fire/">Police &#038; Fire</a></li>
	<li id="menu-item-30425" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30425"><a href="http://www.trumbulltimes.com/category/news/business/">Business</a></li>
	<li id="menu-item-36411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36411"><a href="http://www.trumbulltimes.com/category/news/schools/">Schools</a></li>
	<li id="menu-item-36409" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36409"><a href="http://www.trumbulltimes.com/category/news/entertainment/">Entertainment</a></li>
	<li id="menu-item-30417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30417"><a href="http://www.trumbulltimes.com/category/news/people/">People</a></li>
	<li id="menu-item-57130" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57130"><a href="http://www.trumbulltimes.com/category/news/community/">Community</a></li>
	<li id="menu-item-30479" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30479"><a href="http://www.trumbulltimes.com/category/news/town-government/">Town Government</a></li>
	<li id="menu-item-36412" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36412"><a href="http://www.trumbulltimes.com/category/news/politics-elections/">Politics &#038; Elections</a></li>
	<li id="menu-item-36410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36410"><a href="http://www.trumbulltimes.com/category/news/religion/">Religion</a></li>
	<li id="menu-item-30431" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30431"><a target="_blank" href="http://www.hersamacorn.com/print-archives/">Print Archives</a></li>
	<li id="menu-item-30488" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30488"><a href="http://www.trumbulltimes.com/submissions/">Submissions</a></li>
</ul>
</li>
<li id="menu-item-31898" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-31898"><a href="http://www.trumbulltimes.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-31942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31942"><a href="http://www.trumbulltimes.com/category/sports/high-school-sports/">High School Sports</a></li>
	<li id="menu-item-31946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31946"><a href="http://www.trumbulltimes.com/category/sports/youth-sports/">Youth Sports</a></li>
	<li id="menu-item-31944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31944"><a href="http://www.trumbulltimes.com/category/sports/recreational-sports/">Recreational Sports</a></li>
	<li id="menu-item-31945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31945"><a href="http://www.trumbulltimes.com/category/sports/sports-features/">Sports Features</a></li>
	<li id="menu-item-31943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31943"><a href="http://www.trumbulltimes.com/category/sports/other-sports/">Other Sports News</a></li>
	<li id="menu-item-31940" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31940"><a href="http://www.fciac.net/">FCIAC News</a></li>
	<li id="menu-item-32008" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32008"><a href="http://www.trumbulltimes.com/submissions/">Submissions</a></li>
</ul>
</li>
<li id="menu-item-33885" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33885"><a href="http://www.trumbulltimes.com/category/news/schools/">Schools</a></li>
<li id="menu-item-31405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-31405"><a href="http://www.trumbulltimes.com/category/obituaries/">Obituaries</a>
<ul class="sub-menu">
	<li id="menu-item-31530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31530"><a href="http://www.trumbulltimes.com/category/obituaries/">Obituaries</a></li>
	<li id="menu-item-31520" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31520"><a href="https://hersamsecure.com/obit/">Submit an Obituary</a></li>
</ul>
</li>
<li id="menu-item-31406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-31406"><a href="http://www.trumbulltimes.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-31516" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31516"><a href="http://www.trumbulltimes.com/category/opinion/editorial/">Editorial</a></li>
	<li id="menu-item-31517" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31517"><a href="http://www.trumbulltimes.com/category/opinion/letters-to-the-editor/">Letters to the Editor</a></li>
	<li id="menu-item-31515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-31515"><a href="http://www.trumbulltimes.com/category/opinion/columns/">Columns</a>
	<ul class="sub-menu">
		<li id="menu-item-56677" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56677"><a href="http://www.trumbulltimes.com/category/opinion/columns/jim-cameron-talking-transportation/">Jim Cameron: Talking Transportation</a></li>
		<li id="menu-item-34794" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34794"><a href="http://www.trumbulltimes.com/category/al-columns/al-did-i-say-that/">DId I Say That?</a></li>
		<li id="menu-item-31569" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31569"><a href="http://www.trumbulltimes.com/category/opinion/columns/walshs-wonderings/">Walsh&#8217;s Wonderings</a></li>
		<li id="menu-item-36416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36416"><a href="http://www.trumbulltimes.com/category/al-columns/al-curtain-call/">Curtain Call</a></li>
		<li id="menu-item-36417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36417"><a href="http://www.trumbulltimes.com/category/al-columns/al-the-conscious-cook/">The Conscious Cook</a></li>
		<li id="menu-item-36418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36418"><a href="http://www.trumbulltimes.com/category/al-columns/al-twice-baked-twins/">Twins Judy &#038; Joy</a></li>
	</ul>
</li>
	<li id="menu-item-31684" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31684"><a href="http://www.trumbulltimes.com/cartoons-2/">Cartoon Gallery</a></li>
	<li id="menu-item-31672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31672"><a href="http://www.trumbulltimes.com/submissions/">Submissions</a></li>
</ul>
</li>
<li id="menu-item-36408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children parent menu-item-36408"><a href="http://www.trumbulltimes.com/category/news/community/">Community</a>
<ul class="sub-menu">
	<li id="menu-item-57128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57128"><a href="http://www.trumbulltimes.com/submissions/">Submissions</a></li>
</ul>
</li>
<li id="menu-item-34592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34592"><a href="http://www.trumbulltimes.com/category/al-columns/food/">Food</a></li>
<li id="menu-item-34593" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children parent menu-item-34593"><a href="http://www.trumbulltimes.com/category/al-features/">Arts</a>
<ul class="sub-menu">
	<li id="menu-item-34659" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-34659"><a href="http://www.trumbulltimes.com/category/al-features/">Arts Features</a></li>
	<li id="menu-item-34658" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-34658"><a href="http://www.trumbulltimes.com/category/al-columns/al-stage-screen/">Stage &#038; Screen</a></li>
	<li id="menu-item-34657" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children parent menu-item-34657"><a href="http://www.trumbulltimes.com/category/al-columns/">Columns</a>
	<ul class="sub-menu">
		<li id="menu-item-34727" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34727"><a href="http://www.trumbulltimes.com/category/al-columns/al-curtain-call/">Curtain Call</a></li>
		<li id="menu-item-34732" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34732"><a href="http://www.trumbulltimes.com/category/al-columns/al-the-reel-dad/">The Reel Dad</a></li>
		<li id="menu-item-34734" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34734"><a href="http://www.trumbulltimes.com/category/al-columns/al-tv-movie-menu/">TV / Movie Menu</a></li>
		<li id="menu-item-34729" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34729"><a href="http://www.trumbulltimes.com/category/al-columns/al-stir-crazy/">Stir Crazy</a></li>
		<li id="menu-item-34735" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34735"><a href="http://www.trumbulltimes.com/category/al-columns/al-twice-baked-twins/">Twins Judy &#038; Joy</a></li>
		<li id="menu-item-34731" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34731"><a href="http://www.trumbulltimes.com/category/al-columns/al-the-conscious-cook/">The Conscious Cook</a></li>
		<li id="menu-item-34730" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34730"><a href="http://www.trumbulltimes.com/category/al-columns/al-taking-a-hike/">Taking a Hike</a></li>
		<li id="menu-item-34728" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34728"><a href="http://www.trumbulltimes.com/category/al-columns/al-go-fish/">Go Fish</a></li>
		<li id="menu-item-34726" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34726"><a href="http://www.trumbulltimes.com/category/al-columns/al-a-question-of-etiquette/">A Question of Etiquette</a></li>
	</ul>
</li>
	<li id="menu-item-34783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34783"><a href="http://arts.hersamacorn.com/events/">Events</a></li>
</ul>
</li>
<li id="menu-item-34591" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34591"><a href="http://www.trumbulltimes.com/category/al-columns/al-drive/">Auto</a></li>
<li id="menu-item-31995" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-31995"><a href="http://#">Real Estate</a>
<ul class="sub-menu">
	<li id="menu-item-32026" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32026"><a href="http://www.trumbulltimes.com/vermont-real-estate/">Vermont Real Estate</a></li>
</ul>
</li>
<li id="menu-item-30401" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-30401"><a target="_blank" href="https://hersamsecure.com/classifieds/">Classifieds</a>
<ul class="sub-menu">
	<li id="menu-item-30402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30402"><a target="_blank" href="http://www.hersamacorn.com/classifiedadvertising/">Advertising Information</a></li>
	<li id="menu-item-30403" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30403"><a target="_blank" href="https://classadz.vdata.com/HersamAcorn/UserType.aspx">Submit a Classified Ad</a></li>
</ul>
</li>
<li id="menu-item-30404" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-30404"><a href="http://#nogo">Special Sections</a>
<ul class="sub-menu">
	<li id="menu-item-65492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65492"><a href="http://goldenyears.han.network/">Golden Years</a></li>
	<li id="menu-item-30409" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30409"><a target="_blank" href="http://kidsworld.han.network/">Kid&#8217;s World</a></li>
	<li id="menu-item-30408" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30408"><a target="_blank" href="http://healthandfitness.han.network/">Health &#038; Fitness</a></li>
	<li id="menu-item-30407" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30407"><a target="_blank" href="http://bridal.han.network/">Bridal</a></li>
	<li id="menu-item-30472" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30472"><a target="_blank" href="http://education.han.network/">Education</a></li>
	<li id="menu-item-31988" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31988"><a target="_blank" href="http://arts.hersamacorn.com">Arts &#038; Leisure</a></li>
	<li id="menu-item-30406" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30406"><a target="_blank" href="http://thehomemonthly.com">HOME</a></li>
	<li id="menu-item-30405" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30405"><a target="_blank" href="http://www.trumbullanswerbook.com">Trumbull Answerbook</a></li>
	<li id="menu-item-30412" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30412"><a target="_blank" href="http://hersamacorn.com/medical-services/">Your Health</a></li>
</ul>
</li>
</ul></div>						
	          <div class="middle clear">

               

<div id="content">


<div id="post-65854" class="single post-65854 post type-post status-publish format-standard has-post-thumbnail hentry category-al-features category-al-stage-screen tag-magic-moments tag-steve-scales">

    <div class="hentry-meta">
        <h1>Scales &#038; friends will bring the magic on March 18</h1>
<h2></h3>
        <p class="hentry-meta-data">By <a class="url fn n" href="http://www.trumbulltimes.com/author/arts-and-leisure/" title="View all posts by Arts &#38; Leisure">Arts &#38; Leisure</a> on March 16, 2017 in <a href="http://www.trumbulltimes.com/category/al-features/" rel="category tag">Arts &amp; Leisure Features</a>, <a href="http://www.trumbulltimes.com/category/al-columns/al-stage-screen/" rel="category tag">Stage &amp; Screen</a> &middot; <a href="#comments">0 Comments</a></p>
    </div>

    <div class="hentry-container clear">
                <div class="hentry-middle">
            <div class="hentry-content clear">
                <div id="attachment_29546" class="wp-caption aligncenter" style="width: 750px"><a href="http://al.hanewsmedia.com/wp-content/uploads/sites/32/2017/03/cov-SteveScales-LEAD-PIC-3-16.jpg"><img class="size-full wp-image-65844" src="http://al.hanewsmedia.com/wp-content/uploads/sites/32/2017/03/cov-SteveScales-LEAD-PIC-3-16.jpg" alt="Steve Scales is organizing Magic Moments Live for the Kennedy Center's Autism Project." width="750" height="500" srcset="http://www.trumbulltimes.com/wp-content/uploads/sites/32/2017/03/cov-SteveScales-LEAD-PIC-3-16.jpg 750w, http://www.trumbulltimes.com/wp-content/uploads/sites/32/2017/03/cov-SteveScales-LEAD-PIC-3-16-300x200.jpg 300w, http://www.trumbulltimes.com/wp-content/uploads/sites/32/2017/03/cov-SteveScales-LEAD-PIC-3-16-360x240.jpg 360w" sizes="(max-width: 750px) 100vw, 750px" /></a></p>
<p class="wp-caption-text">Steve Scales is organizing Magic Moments Live for the Kennedy Center&#8217;s Autism Project.</p>
</div>
<p><b></b><i><span style="font-weight: 400;">by Keith Loria — </span></i>Music fans know Steve Scales as the percussionist extraordinaire from the Talking Heads and the artist has also recorded with the likes of The Psychedelic Furs, The Violent Femmes, Tina Turner and Yoko Ono. He’s putting his skills and connections together for a special show Saturday night, March 18, at the Quick Center at Fairfield University.</p>
<p><span style="font-weight: 400;">After more than 30 years in the music biz, Scales decided to do something a little different. The long-time Milford resident has gone back to college. As part of his studies, he’s been interning with the Kennedy Center, which is based in Trumbull.</span></p>
<p><span style="font-weight: 400;">Scales is pursuing a bachelor of science degree in human services from the University of Bridgeport and is completing a 100-hour practicum using his musical and drumming skills to connect with people with disabilities served by the Kennedy Center.</span></p>
<p>“Someone called me and asked if I would record on some of her stuff, and I found out she worked at the Kennedy Center, and I wound up going in and asking for an internship,” Scales said. “They used to have a woman come in on Fridays to do music with the clients, and I would bring my drums in and we would play, and I was asked to come back and do a drum circle.”</p>
<p>For the past year, Scales has been arranging drum circles with Kennedy Center consumers in Milford who participate in the rehabilitation agency’s Community Experience Programs.</p>
<p>“I kick all of the caretakers out, we sit around in a big circle and play drums, and they love it,” Scales said. “The president of the Kennedy Center found out about it and wanted to meet me, so he came to the site and asked if I would help with a fundraiser.”</p>
<div id="attachment_29544" class="wp-caption alignleft" style="width: 300px"><a href="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/03/cov-ChrisTina-3-16.jpg"><img class="size-medium wp-image-29544" src="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/03/cov-ChrisTina-3-16-300x225.jpg" alt="Tina Weymouth and Chris Frantz." width="300" height="225" /></a></p>
<p class="wp-caption-text">Tina Weymouth and Chris Frantz.</p>
</div>
<p>This was in 2016, and Scales invited some of his musician friends to join him on stage and quickly threw together a show.</p>
<p>“It went great, and we decided this was something we needed to do every year,” Scales said. “Since I had more time to plan this one, I reached out to more of my friends and this year we are going to put on an event that’s much bigger and better.”</p>
<p><span style="font-weight: 400;">On March 18, Scales is bringing a number of his musician friends together for Magic Moments Live: A Benefit Concert Event for The Kennedy Center Autism Project.</span></p>
<div id="attachment_29545" class="wp-caption alignright" style="width: 300px"><a href="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/03/cov-Nona-Hendryx-3-16.jpg"><img class="size-medium wp-image-29545" src="http://al.hanewsmedia.com/wp-content/uploads/sites/49/2017/03/cov-Nona-Hendryx-3-16-300x212.jpg" alt="Nona Hendryx." width="300" height="212" /></a></p>
<p class="wp-caption-text">Nona Hendryx.</p>
</div>
<p>Joining the former Talking Heads star on stage will be his former band mates Tina Weymouth and Chris Frantz, founders of the Tom Tom Club; and Grammy-nominated Nona Hendryx.</p>
<p>Keith Fluitt will serve as lead vocalist and other musicians include guitarist Andy Abel of Twisted Vine, drummer Benny Gramm, bass player Dave Livolsi, keyboardist Scott Beckham and saxophonist Dan Cipriano. For backup singers, Scales is using some of his classmates from school.</p>
<p>“It’s getting bigger and bigger and we’re trying to get a lot of people interested and people are still coming in,” Scales said.</p>
<p>He promises that there will be some Talking Heads music played, as well as other favorites of his from his years in the music biz.</p>
<p>The event kicks off with a mix and mingle, open bar and food stations at 6:30 p.m., followed by the concert in the Kelley Theatre at 8 p.m. After the music stops, the evening continues with the Black Box After Party at 10 p.m., which includes dessert and drinks plus a meet-and-greet with Scales and the other musicians. Jo Ann McMullen, vice president of development for the Kennedy Center, notes the</p>
<p><span style="font-weight: 400;">Magic Moments event serves as the main funding source for the Kennedy Center Autism Project, which benefits more than 500 local children with autism spectrum disorders and their families. The money raised is earmarked to help the Kennedy Center provide comprehensive programs at affordable rates for all families in the community.</span></p>
<p><span style="font-weight: 400;">“This is our 11</span><span style="font-weight: 400;">th</span><span style="font-weight: 400;"> year for this event, and it benefits our autism project for children for those 4 to 21. It’s always been one of our largest events and we always try to do some sort of entertainment, and we’re very excited to have Steve and his friends come out this year,” she said. “There’s very little state funding for autism programs, so this is an important event for us and very beneficial to the program itself.”</span></p>
<p>In addition to taking part in the entire evening’s festivities, those who just want to see the concert will have that option as well.</p>
<p>The cause is an important one for Scales who is studying to be a counselor. He will graduate in May and has already begun looking at graduate schools.</p>
<p>“I’m a Vietnam veteran and when we came home, there was no therapy for us,” he said. “Spiritually walking around church, and talking to God, I got a message to go and become a counselor and my main focus was to help those with PTSD, although now that I work with the mentally challenged, I am thinking of working there.”</p>
<p>Not that he’s hanging up his musical career, altogether. In fact, he believes that his music will only help him in his efforts to help.</p>
<p>“I’ve been to the top of the mountain musically; I’ve played with everybody and played when music was really good,” he said. “I’m not that great on music today. I knew it was time to do something else and I had this calling.”</p>
<p>He does admit that if there were a call for the Heads to get back together, he would do that in a heartbeat. For now, he’s excited about what lies ahead and hopes to see many of his fans out at the Magic Moments.</p>
<p>“This is a benefit for a great cause,” he said. “It’s a great band and it’s going to be a great show and we’re going to have lots of fun.”</p>
<p><span style="font-weight: 400;">Tickets for Magic Moments Live are $125. The concert only is $40. Both can be purchased by calling 203-365-8522, ext. 216; or by visiting </span><a href="http://www.thekennedycenterinc.org/"><span style="font-weight: 400;">www.thekennedycenterinc.org</span></a><span style="font-weight: 400;">. </span></p>
<p><span style="font-weight: 400;">  </span></p>
<p><span style="font-weight: 400;">  </span></p>
<p>&nbsp;</p>
<div class='yarpp-related'>
<h3>Related posts:</h3><ol>
<li><a href="http://www.trumbulltimes.com/35175/some-classics-including-spielburgs/" rel="bookmark" title="Some classics, including Spielburg&#8217;s">Some classics, including Spielburg&#8217;s </a></li>
<li><a href="http://www.trumbulltimes.com/35676/inside-out-a-sweet-film-for-all-ages/" rel="bookmark" title="Inside Out, a sweet film for all ages">Inside Out, a sweet film for all ages </a></li>
<li><a href="http://www.trumbulltimes.com/36200/paying-tribute-to-omar-sharif/" rel="bookmark" title="Paying tribute to Omar Sharif">Paying tribute to Omar Sharif </a></li>
<li><a href="http://www.trumbulltimes.com/36950/annie-get-your-gun-at-richter/" rel="bookmark" title="Annie Get Your Gun at Richter">Annie Get Your Gun at Richter </a></li>
</ol>
</div>

            </div>
            <div class="hentry-footer">
                <p class="hentry-tags">Tags: <a href="http://www.trumbulltimes.com/tag/magic-moments/" rel="tag">Magic Moments</a>, <a href="http://www.trumbulltimes.com/tag/steve-scales/" rel="tag">Steve Scales</a></p>                                                <div class="hentry-navigation">
                    <div class="hentry-navigation-inn clear">
                                                    <a class="hentry-navigation-prev" href="http://www.trumbulltimes.com/65856/chory-let-your-voice-be-heard/">
                                <em>Previous Post</em>
                                <span>Chory: Let your voice be heard</span>
                            </a>
                                                    <a class="hentry-navigation-next" href="http://www.trumbulltimes.com/65860/yankee-fisherman-thursday-march-16-2017/">
                                <em>Next Post</em>
                                <span>Yankee Fisherman, Thursday, March 16, 2017</span>
                            </a>
                                                    <div class="hentry-navigation-line"></div>
                    </div>
                </div>

              <!--  <div class='yarpp-related'>
<h3>Related posts:</h3><ol>
<li><a href="http://www.trumbulltimes.com/35175/some-classics-including-spielburgs/" rel="bookmark" title="Some classics, including Spielburg&#8217;s">Some classics, including Spielburg&#8217;s </a></li>
<li><a href="http://www.trumbulltimes.com/35676/inside-out-a-sweet-film-for-all-ages/" rel="bookmark" title="Inside Out, a sweet film for all ages">Inside Out, a sweet film for all ages </a></li>
<li><a href="http://www.trumbulltimes.com/36200/paying-tribute-to-omar-sharif/" rel="bookmark" title="Paying tribute to Omar Sharif">Paying tribute to Omar Sharif </a></li>
</ol>
</div>
-->

            </div>
        </div>
				        <div class="hentry-sidebar">
                        <div class="hentry-widget hentry-author">
                <h6>About author</h6>
                <div class="hentry-author-meta clear">
                    <img alt='Arts &amp; Leisure' src='http://arts.hanewsmedia.com/wp-content/uploads/sites/22/2015/06/Arts-amp-Leisure_avatar_1435260026.png' class='avatar avatar-60 photo' height='60' width='60' />                    <p><a href="http://www.trumbulltimes.com/author/arts-and-leisure/">Arts &#38; Leisure</a></p>
                   <br />                 </div>
                <div class="hentry-author-about"></div>
            </div>
            
           <!--- -->

            
            
        </div>
				
                <div id="sharebox">
            <div class="share-item"><a href="http://twitter.com/share" class="twitter-share-button" data-count="vertical">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></div>
            <div class="share-item">
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div class="fb-like" data-send="false" data-href="http://www.trumbulltimes.com/65854/scales-friends-will-bring-the-magic-on-march-18/" data-layout="box_count" data-width="49" data-show-faces="false"></div>
						</div>

<div class="share-item"><script type="text/javascript" src="http://www.reddit.com/static/button/button3.js"></script></div>
            <div class="share-item"><script src="http://www.stumbleupon.com/hostedbadge.php?s=5"></script></div>
            <div class="share-item"><script type="text/javascript" src="http://platform.linkedin.com/in.js"></script><script type="in/share" data-url="http://www.trumbulltimes.com/65854/scales-friends-will-bring-the-magic-on-march-18/" data-counter="top"></script></div>
     
						<div class="share-item">
<g:plusone size="tall"></g:plusone>
<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>
						</div>
        </div>
        
    </div>

    <div class="clear"></div>
    
        <div class="agree"><p>By participating in the comments section of this site you are agreeing to our <a href="http://www.trumbulltimes.com/privacy-policy-user-agreement/">Privacy Policy and User Agreement</a></p></div>

    
<div id="disqus_thread">
    </div>


</div> <!-- .single -->


</div><!-- #content -->

<div id="sidebar">
    <div id="execphp-12" class="widget_execphp widget">			<div class="execphpwidget"><a href="http://live.han.network"><img src="http://trumbulltimes.hanewsmedia.com/wp-content/uploads/sites/32/2016/09/han-network-banner.png" alt="Live HAN Netowrk" width="300" height="90" class="aligncenter size-full wp-image-58945" /></a></div>
		</div><div id="execphp-13" class="widget_execphp widget">			<div class="execphpwidget"><div style="padding-top:10px;">
<a href="http://live.han.network/schedule/" rel="attachment wp-att-486978"><img src="http://hanradio.hanewsmedia.com/wp-content/uploads/sites/46/2016/01/programschedule.jpg" alt="programschedule" width="300" height="40" class="aligncenter size-full wp-image-486978" /></a></div></div>
		</div><div id="execphp-2" class="widget_execphp widget">			<div class="execphpwidget"><div style="padding-bottom:15px;padding-top:15px;">
<!-- TrumbullTimesSquare1 -->
<div id='div-gpt-ad-1357320716616-9' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1357320716616-9'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- TrumbullTimesRectangle1 -->
<div id='div-gpt-ad-1357320716616-6' style='width:300px; height:75px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1357320716616-6'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- TrumbullTimesSquare2 -->
<div id='div-gpt-ad-1357320716616-10' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1357320716616-10'); });
</script>
</div></div></div>
		</div><div id="execphp-11" class="widget_execphp widget"><h3 class="widget-title">Latest Tweets</h3>			<div class="execphpwidget">            <a class="twitter-timeline"  href="https://twitter.com/TrumbullTimes" data-widget-id="657232992264433664">Tweets by @TrumbullTimes</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
          </div>
		</div><div id="execphp-4" class="widget_execphp widget">			<div class="execphpwidget"><div style="padding-bottom:15px;padding-top:15px;">
<!-- TrumbullTimesSquare3 -->
<div id='div-gpt-ad-1357320716616-11' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1357320716616-11'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- TrumbullTimesRectangle2 -->
<div id='div-gpt-ad-1357320716616-7' style='width:300px; height:75px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1357320716616-7'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- TrumbullTimesSquare4 -->
<div id='div-gpt-ad-1357320716616-12' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1357320716616-12'); });
</script>
</div></div>
<div style="padding-bottom:15px;">
<!-- TrumbullTimesSquare5 -->
<div id='div-gpt-ad-1357320716616-15' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1357320716616-15'); });
</script>
</div></div></div>
		</div><div id="text-2" class="widget_text widget">			<div class="textwidget"><a href="http://feeds.feedburner.com/TrumbullTimesNews" target="_blank"><img class="alignleft size-full wp-image-24531" style="margin-right: 10px;" alt="news-rss" src="http://hersamacorn.com/img/news-rss.jpg" width="145" height="30" /></a><a href="http://feeds.feedburner.com/TrumbullTimesSports" target="_blank"><img alt="sports-rss" src="http://hersamacorn.com/img/sports-rss.jpg" width="145" height="30" /></a></div>
		</div></div><!-- #sidebar -->

            </div> <!-- .middle -->
            <div class="bottom-widgetarea">
                <div class="bottom-widgetarea-inn clear">

                                                        </div>
            </div>
            <div class="footer clear">

            
                <div class="footer-leftpart">
                    <a class="logo-footer" href="http://www.trumbulltimes.com">
                        <img src="http://trumbulltimes.hanewsmedia.com/wp-content/uploads/sites/32/2015/08/tt-hannetwork-bottom.png" alt="Trumbull Times"/>                    </a>
                </div>
                <div class="footer-middlepart">
					<div id="footer-widget">			<div class="execphpwidget"><div class="footlist"><p><a href="http://www.hersamacorn.com"><strong>HAN Network News Sites</strong></a>
</p>
<p><strong><a href="http://live.han.network">Live.HAN.Network</a></strong> | <a href="http://www.thebridgeportnews.com">Bridgeport News</a> | <a href="http://www.darientimes.com">Darien Times</a><br />
  <a href="http://www.eastoncourier.com">Easton Courier</a> | <a href="http://www.fairfield-sun.com">Fairfield Sun</a> | <a href="http://www.greenwich-post.com">Greenwich Post</a><br />    <a href="http://www.lewisboroledger.com">Lewisboro Ledger</a>  |  <a href="http://www.milfordmirror.com">Milford Mirror</a>  |  
  <a href="http://www.monroecourier.com">Monroe Courier</a><br /><a href="http://www.ncadvertiser.com">New Canaan Advertiser</a>  |  <a href="http://www.thereddingpilot.com">Redding Pilot</a>  |  
  <a href="http://www.theridgefieldpress.com">Ridgefield Press</a><br /><a href="http://www.sheltonherald.com">Shelton Herald</a>  |  
<a href="http://www.stratfordstar.com">Stratford Star</a>  |  <a href="http://www.trumbulltimes.com">Trumbull Times </a><br />
<a href="http://www.thewestonforum.com">Weston Forum</a>  |  <a href="http://www.wiltonbulletin.com">Wilton Bulletin
  </a>
</p></div></div>
		</div>                </div>

            <ul id="menu-footer-left-linkset" class="footer-linkset"><li id="menu-item-28931" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28931"><a target="_blank" href="http://arts.hersamacorn.com">Arts &#038; Leisure</a></li>
<li id="menu-item-31409" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31409"><a target="_blank" href="http://www.hersamacorn.com/newspaper-advertising/">Advertise</a></li>
<li id="menu-item-31410" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31410"><a target="_blank" href="https://hersamsecure.com/classifieds/">Classifieds</a></li>
<li id="menu-item-31488" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31488"><a target="_blank" href="http://www.hersamacorn.com/article-reprints/">Article Reprints</a></li>
<li id="menu-item-31489" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31489"><a target="_blank" href="http://www.hersamacorn.com/print-archives/">Print Archives</a></li>
<li id="menu-item-31490" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31490"><a target="_blank" href="https://classadz.vdata.com/HersamAcornCirc/SelectOption.aspx">Subscriptions</a></li>
<li id="menu-item-31667" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31667"><a href="http://www.trumbulltimes.com/privacy-policy-user-agreement-2/">Privacy Policy &#038; User Agreement</a></li>
</ul>
            <ul id="menu-footer-right-linkset" class="footer-linkset"><li id="menu-item-31906" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31906"><a target="_blank" href="https://twitter.com/Trumbulltimes">Follow us on Twitter</a></li>
<li id="menu-item-30394" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30394"><a target="_blank" href="http://www.facebook.com/trumbulltimes">Like us on Facebook</a></li>
<li id="menu-item-30396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30396"><a target="_blank" href="http://www.trumbullanswerbook.com">Trumbull Answerbook</a></li>
<li id="menu-item-32006" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32006"><a href="http://www.trumbulltimes.com/submissions/">Submissions</a></li>
<li id="menu-item-31687" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31687"><a href="http://www.trumbulltimes.com/about-us/">About Us</a></li>
<li id="menu-item-31668" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31668"><a href="http://www.trumbulltimes.com/contact-us/">Contact Us</a></li>
</ul>
            </div><!-- .footer -->
            <div class="copyrights">
                <!-- <p><a href="http://www.trumbulltimes.com">Trumbull Times</a> &copy; 2017 All Rights Reserved</p> -->
                <p>© HAN Network. All rights reserved. Trumbull Times, 1000 Bridgeport Avenue, Shelton, CT 06484</p>            </div>
            <div class="credits">
                <p>Designed by <a href="http://wpshower.com">WPSHOWER</a></p>
                <p>Powered by <a href="http://wordpress.org">WordPress</a></p>
            </div>
            <div class="clear"></div>
        </div> <!-- .wrapper -->

        <script type="text/javascript">if(window.aiModifyParent) {aiModifyParent();}</script>
<!-- WP Audio player plugin v1.9.6 - https://www.tipsandtricks-hq.com/wordpress-audio-music-player-plugin-4556/ -->
    <script type="text/javascript">
        soundManager.useFlashBlock = true; // optional - if used, required flashblock.css
        soundManager.url = 'http://trumbulltimes.hanewsmedia.com/wp-content/plugins/compact-wp-audio-player/swf/soundmanager2.swf';
        function play_mp3(flg, ids, mp3url, volume, loops)
        {
            //Check the file URL parameter value
            var pieces = mp3url.split("|");
            if (pieces.length > 1) {//We have got an .ogg file too
                mp3file = pieces[0];
                oggfile = pieces[1];
                //set the file URL to be an array with the mp3 and ogg file
                mp3url = new Array(mp3file, oggfile);
            }

            soundManager.createSound({
                id: 'btnplay_' + ids,
                volume: volume,
                url: mp3url
            });

            if (flg == 'play') {
    stop_all_tracks();                soundManager.play('btnplay_' + ids, {
                    onfinish: function() {
                        if (loops == 'true') {
                            loopSound('btnplay_' + ids);
                        }
                        else {
                            document.getElementById('btnplay_' + ids).style.display = 'inline';
                            document.getElementById('btnstop_' + ids).style.display = 'none';
                        }
                    }
                });
            }
            else if (flg == 'stop') {
    //soundManager.stop('btnplay_'+ids);
                soundManager.pause('btnplay_' + ids);
            }
        }
        function show_hide(flag, ids)
        {
            if (flag == 'play') {
                document.getElementById('btnplay_' + ids).style.display = 'none';
                document.getElementById('btnstop_' + ids).style.display = 'inline';
            }
            else if (flag == 'stop') {
                document.getElementById('btnplay_' + ids).style.display = 'inline';
                document.getElementById('btnstop_' + ids).style.display = 'none';
            }
        }
        function loopSound(soundID)
        {
            window.setTimeout(function() {
                soundManager.play(soundID, {onfinish: function() {
                        loopSound(soundID);
                    }});
            }, 1);
        }
        function stop_all_tracks()
        {
            soundManager.stopAll();
            var inputs = document.getElementsByTagName("input");
            for (var i = 0; i < inputs.length; i++) {
                if (inputs[i].id.indexOf("btnplay_") == 0) {
                    inputs[i].style.display = 'inline';//Toggle the play button
                }
                if (inputs[i].id.indexOf("btnstop_") == 0) {
                    inputs[i].style.display = 'none';//Hide the stop button
                }
            }
        }
    </script>
    <script id="dsq-count-scr" src="//trumbulltimes.disqus.com/count.js" async></script><!-- Powered by WPtouch Pro: 4.3.6 --><script>window._popup_data = {"ajaxurl":"http:\/\/www.trumbulltimes.com\/wp-admin\/admin-ajax.php","do":"get_data","ajax_data":{"orig_request_uri":"\/65854\/scales-friends-will-bring-the-magic-on-march-18\/"}};</script><link rel='stylesheet' id='yarppRelatedCss-css'  href='http://www.trumbulltimes.com/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=f23620b5541c963ee00661d915038a42' type='text/css' media='all' />
<script type='text/javascript' src='http://platform.twitter.com/widgets.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://apis.google.com/js/plusone.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://platform.linkedin.com/in.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-includes/js/comment-reply.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201711'></script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/plugins/advanced-iframe/js/ai.js?ver=621146'></script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript' src='http://trumbulltimes.hanewsmedia.com/wp-content/plugins/popover/js/public.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var author = {"name":"Arts & Leisure"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/themes/unspoken-tt/lib/js/google.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-includes/js/wp-embed.min.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.3","language":""},"disqusIdentifier":"65854 http:\/\/www.trumbulltimes.com\/?p=65854","disqusShortname":"trumbulltimes","disqusTitle":"Scales & friends will bring the magic on March 18","disqusUrl":"http:\/\/www.trumbulltimes.com\/65854\/scales-friends-will-bring-the-magic-on-march-18\/","options":{"manualSync":"1"},"postId":"65854"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=f23620b5541c963ee00661d915038a42'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"trumbulltimes"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.trumbulltimes.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=f23620b5541c963ee00661d915038a42'></script>

        
	</body>
</html>
